mariadb versions and koha

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

mariadb versions and koha

Laurent Ducos
Hello
We are currently using version 10.0 of mariadb with koha.
We are planning a upgrade.
Have you noticed problems with versions 10.1 10.2, 10.3 or 10.4?

--
Laurent Ducos
Administrateur système et réseaux chez BibLibre
IT system and network administrator at BibLibre
_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
Reply | Threaded
Open this post in threaded view
|

Re: mariadb versions and koha

Andreas Hedström Mace-2
Hi!

We are using 10.3 (from 10.3.10 to 10.3-15 on different servers). Have not experiences any specific issues relating to MariaDB as far as we have noticed.

Best regards,
Andreas

Andreas Hedström Mace 
Business Developer (Systems and Development)
Stockholm University Library
Stockholm University
106 91 Stockholm 
Tel: +46 (0) 8 16 49 17 
su.se/english/library




-----Ursprungligt meddelande-----
Från: Koha-devel <[hidden email]> För Laurent Ducos
Skickat: den 22 augusti 2019 10:50
Till: [hidden email]
Ämne: [Koha-devel] mariadb versions and koha

Hello
We are currently using version 10.0 of mariadb with koha.
We are planning a upgrade.
Have you noticed problems with versions 10.1 10.2, 10.3 or 10.4?

--
Laurent Ducos
Administrateur système et réseaux chez BibLibre IT system and network administrator at BibLibre _______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/ git : http://git.koha-community.org/ bugs : http://bugs.koha-community.org/
_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
Reply | Threaded
Open this post in threaded view
|

Re: mariadb versions and koha

Laurent Ducos
Currently, I am testing Koha with mariadb 10.4.
For simple use, everything seems to be fine.
This test is an upgrade from 10.0 to 10.1 then from 10.1 to 10.2 then from 10.2 to 10.3 then 10.3 to 10.4

Laurent Ducos
Administrateur système et réseaux chez BibLibre

22 août 2019 11:02 "Andreas Hedström Mace" <[hidden email]> a écrit:

> Hi!
>
> We are using 10.3 (from 10.3.10 to 10.3-15 on different servers). Have not experiences any specific
> issues relating to MariaDB as far as we have noticed.
>
> Best regards,
> Andreas
>
> Andreas Hedström Mace
> Business Developer (Systems and Development)
> Stockholm University Library
> Stockholm University
> 106 91 Stockholm
> Tel: +46 (0) 8 16 49 17
> su.se/english/library
>
> -----Ursprungligt meddelande-----
> Från: Koha-devel <[hidden email]> För Laurent Ducos
> Skickat: den 22 augusti 2019 10:50
> Till: [hidden email]
> Ämne: [Koha-devel] mariadb versions and koha
>
> Hello
> We are currently using version 10.0 of mariadb with koha.
> We are planning a upgrade.
> Have you noticed problems with versions 10.1 10.2, 10.3 or 10.4?
>
> --
> Laurent Ducos
> Administrateur système et réseaux chez BibLibre IT system and network administrator at BibLibre
> _______________________________________________
> Koha-devel mailing list
> [hidden email]
> https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
> website : http://www.koha-community.org git : http://git.koha-community.org bugs :
> http://bugs.koha-community.org
_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
Reply | Threaded
Open this post in threaded view
|

Re: mariadb versions and koha

Mark Tompsett
In reply to this post by Laurent Ducos
Greetings,

In order to avoid the auto-increment bug, you really want 10.3 or higher. :)

GPML,
Mark Tompsett


-----Original Message-----
From: Laurent Ducos
Sent: Thursday, August 22, 2019 4:50 AM
To: [hidden email]
Subject: [Koha-devel] mariadb versions and koha

Hello
We are currently using version 10.0 of mariadb with koha.
We are planning a upgrade.
Have you noticed problems with versions 10.1 10.2, 10.3 or 10.4?

--
Laurent Ducos
Administrateur système et réseaux chez BibLibre
IT system and network administrator at BibLibre
_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/ 

_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
Reply | Threaded
Open this post in threaded view
|

Re: mariadb versions and koha

Tomas Cohen Arazi
We've been testing MySQL 8 as well, without major issues, besides the need to solve the authentication issue (i.e. making mysql-client v5.x work).

Regards

El jue., 22 ago. 2019 a las 22:53, Mark Tompsett (<[hidden email]>) escribió:
Greetings,

In order to avoid the auto-increment bug, you really want 10.3 or higher. :)

GPML,
Mark Tompsett


-----Original Message-----
From: Laurent Ducos
Sent: Thursday, August 22, 2019 4:50 AM
To: [hidden email]
Subject: [Koha-devel] mariadb versions and koha

Hello
We are currently using version 10.0 of mariadb with koha.
We are planning a upgrade.
Have you noticed problems with versions 10.1 10.2, 10.3 or 10.4?

--
Laurent Ducos
Administrateur système et réseaux chez BibLibre
IT system and network administrator at BibLibre
_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/


--
Tomás Cohen Arazi
Theke Solutions (http://theke.io)
✆ +54 9351 3513384
GPG: B2F3C15F

_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
Reply | Threaded
Open this post in threaded view
|

Re: mariadb versions and koha

Laurent Ducos
the update has many advantages and new features.

There is a new feature with 10.4 that limits the size of temporary tables. This is useful when running poorly constructed reports (Cartesian products) that can generate gigabytes of temporary tables. For exemple:

[mysqld]
innodb_temp_data_file_path = ibtmp1:12M:autoextend:max:1G
did anyone ever test this feature?

Laurent Ducos
Administrateur système et réseaux chez BibLibre


23 août 2019 04:24 "Tomas Cohen Arazi" <[hidden email]> a écrit:
We've been testing MySQL 8 as well, without major issues, besides the need to solve the authentication issue (i.e. making mysql-client v5.x work).
Regards
El jue., 22 ago. 2019 a las 22:53, Mark Tompsett (<[hidden email]>) escribió:
Greetings,

In order to avoid the auto-increment bug, you really want 10.3 or higher. :)

GPML,
Mark Tompsett


-----Original Message-----
From: Laurent Ducos
Sent: Thursday, August 22, 2019 4:50 AM
To: [hidden email]
Subject: [Koha-devel] mariadb versions and koha

Hello
We are currently using version 10.0 of mariadb with koha.
We are planning a upgrade.
Have you noticed problems with versions 10.1 10.2, 10.3 or 10.4?

--
Laurent Ducos
Administrateur système et réseaux chez BibLibre
IT system and network administrator at BibLibre
_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
--
Tomás Cohen Arazi
Theke Solutions (http://theke.io)
✆ +54 9351 3513384
GPG: B2F3C15F

_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
Reply | Threaded
Open this post in threaded view
|

Re: mariadb versions and koha

MartinRenvoize
Our CI framework currently tests against MySQL5.5, MariaDB10.1 and will soon also be testing against MariaDB10.3 (Once we have D10 building packages building correctly).

We have chosen these DB versions as they're the ones shipped by default with D8, D9 and U18 which are our current listed supported OS's. D8 will soon be deprecated (Debian themselves are dropping support come June 2020) and we are in the process of adopting D10 support (and hence MariaDB10.3).

As those are the only DBs we are currently regularly testing I would suggest those are the ones people generally use, though of course if issues are reported against other we will accept bugfixes so long as they do not break the existing support but we cannot guarantee stability around the newer DBs otherwise.

It does raise other questions as I've recently hit in a few occasions where recent MariaDB and MySQL have started to diverge more and as such it's getting increasingly difficult to support both in the current manor we are.

Martin Renvoize

Development Team Manager

 

 

Phone: +44 (0) 1483 378728

Mobile: +44 (0) 7725 985 636

Email: [hidden email]

Fax: +44 (0) 800 756 6384


www.ptfs-europe.com

 

 

 

Registered in the United Kingdom No. 06416372   VAT Reg No. 925 7211 30


The information contained in this email message may be privileged, confidential and protected from disclosure. If you are not the intended recipient, any dissemination, distribution or copying is strictly prohibited. If you think that you have received this email message in error, please email the sender at [hidden email]




On Fri, 23 Aug 2019 at 08:44, Laurent Ducos <[hidden email]> wrote:
the update has many advantages and new features.

There is a new feature with 10.4 that limits the size of temporary tables. This is useful when running poorly constructed reports (Cartesian products) that can generate gigabytes of temporary tables. For exemple:

[mysqld]
innodb_temp_data_file_path = ibtmp1:12M:autoextend:max:1G
did anyone ever test this feature?

Laurent Ducos
Administrateur système et réseaux chez BibLibre

23 août 2019 04:24 "Tomas Cohen Arazi" <[hidden email]> a écrit:
We've been testing MySQL 8 as well, without major issues, besides the need to solve the authentication issue (i.e. making mysql-client v5.x work).
Regards
El jue., 22 ago. 2019 a las 22:53, Mark Tompsett (<[hidden email]>) escribió:
Greetings,

In order to avoid the auto-increment bug, you really want 10.3 or higher. :)

GPML,
Mark Tompsett


-----Original Message-----
From: Laurent Ducos
Sent: Thursday, August 22, 2019 4:50 AM
To: [hidden email]
Subject: [Koha-devel] mariadb versions and koha

Hello
We are currently using version 10.0 of mariadb with koha.
We are planning a upgrade.
Have you noticed problems with versions 10.1 10.2, 10.3 or 10.4?

--
Laurent Ducos
Administrateur système et réseaux chez BibLibre
IT system and network administrator at BibLibre
_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
--
Tomás Cohen Arazi
Theke Solutions (http://theke.io)
✆ +54 9351 3513384
GPG: B2F3C15F
_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
Reply | Threaded
Open this post in threaded view
|

Re: mariadb versions and koha

Marcel de Rooy
See also the discussion on the dev meeting of Nov 6 now.

I just saw another bug (23960) about an issue with MariaDB 10.3.
Can't we add a keyword in Bugzilla to mark such ones to find them back easier ? sql_version_dependent or something ?


Van: Koha-devel <[hidden email]> namens Renvoize, Martin <[hidden email]>
Verzonden: maandag 4 november 2019 17:09
Aan: Laurent Ducos <[hidden email]>
CC: Koha Devel <[hidden email]>
Onderwerp: Re: [Koha-devel] mariadb versions and koha
 
Our CI framework currently tests against MySQL5.5, MariaDB10.1 and will soon also be testing against MariaDB10.3 (Once we have D10 building packages building correctly).

We have chosen these DB versions as they're the ones shipped by default with D8, D9 and U18 which are our current listed supported OS's. D8 will soon be deprecated (Debian themselves are dropping support come June 2020) and we are in the process of adopting D10 support (and hence MariaDB10.3).

As those are the only DBs we are currently regularly testing I would suggest those are the ones people generally use, though of course if issues are reported against other we will accept bugfixes so long as they do not break the existing support but we cannot guarantee stability around the newer DBs otherwise.

It does raise other questions as I've recently hit in a few occasions where recent MariaDB and MySQL have started to diverge more and as such it's getting increasingly difficult to support both in the current manor we are.

Martin Renvoize

Development Team Manager

 

 

Phone: +44 (0) 1483 378728

Mobile: +44 (0) 7725 985 636

Email: [hidden email]

Fax: +44 (0) 800 756 6384


www.ptfs-europe.com

 

 

 

Registered in the United Kingdom No. 06416372   VAT Reg No. 925 7211 30


The information contained in this email message may be privileged, confidential and protected from disclosure. If you are not the intended recipient, any dissemination, distribution or copying is strictly prohibited. If you think that you have received this email message in error, please email the sender at [hidden email]




On Fri, 23 Aug 2019 at 08:44, Laurent Ducos <[hidden email]> wrote:
the update has many advantages and new features.

There is a new feature with 10.4 that limits the size of temporary tables. This is useful when running poorly constructed reports (Cartesian products) that can generate gigabytes of temporary tables. For exemple:

[mysqld]
innodb_temp_data_file_path = ibtmp1:12M:autoextend:max:1G
did anyone ever test this feature?

Laurent Ducos
Administrateur système et réseaux chez BibLibre

23 août 2019 04:24 "Tomas Cohen Arazi" <[hidden email]> a écrit:
We've been testing MySQL 8 as well, without major issues, besides the need to solve the authentication issue (i.e. making mysql-client v5.x work).
Regards
El jue., 22 ago. 2019 a las 22:53, Mark Tompsett (<[hidden email]>) escribió:
Greetings,

In order to avoid the auto-increment bug, you really want 10.3 or higher. :)

GPML,
Mark Tompsett


-----Original Message-----
From: Laurent Ducos
Sent: Thursday, August 22, 2019 4:50 AM
To: [hidden email]
Subject: [Koha-devel] mariadb versions and koha

Hello
We are currently using version 10.0 of mariadb with koha.
We are planning a upgrade.
Have you noticed problems with versions 10.1 10.2, 10.3 or 10.4?

--
Laurent Ducos
Administrateur système et réseaux chez BibLibre
IT system and network administrator at BibLibre
_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
--
Tomás Cohen Arazi
Theke Solutions (http://theke.io)
✆ +54 9351 3513384
GPG: B2F3C15F
_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/