Trouble in setting up kohadevbox on Win10 prof

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Trouble in setting up kohadevbox on Win10 prof

Indranil Das Gupta-3
Hi all,

I'm trying to setup kohadevbox on a Windows 10 prof laptop. I'm going after stretch64 

Things I've done so far:

1. I had to switch the distribution to https://app.vagrantup.com/digital-port/boxes/debian-stretch64 because otherwise I was hitting the missing linux-headers for vbox guest additions.

2. Ran SMB=1 SKIP_WEBINSTALLER=1 CREATE_ADMIN_USER=1 LOCAL_ANSIBLE=1 SYNC_REPO="/home/vagrant/kohaclone" vagrant up

3. I've the VM created, can ssh into it both as `vagrant ssh` as well as via putty

4. But no cheese when i try to access http://localhost:8081 either inside the VM or from my host box

5. the .deb installation did go through, because there is /usr/share/koha and the koha-* commands are accessible e.g. koha-list. koha-passwd so package got installed.

6. /home/vagrant/kohaclone is empty and that I guess is the root of my problems because the installation has gotten gitified and there is nothing there at the moment.

7. I'm now manually doing a `git clone http://git.koha-community.org/koha.git kohaclone` in /home/vagrant to see if that makes a difference.

My question: kohadevbox README.md says - "A clone of the official Koha Git repo, or a NFS-mounted git repository from your host machine." 

So what am I missing here? Cluesticks / brickbats welcome... and expected :-)

thanks

--
Indranil Das Gupta
L2C2 Technologies

Phone : +91-98300-20971
WWW : http://www.l2c2.co.in
Blog    : http://blog.l2c2.co.in
IRC     : indradg on irc://irc.freenode.net
Twitter : indradg

_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
Reply | Threaded
Open this post in threaded view
|

Re: Trouble in setting up kohadevbox on Win10 prof

dcook

Hey Indranil,

 

I’m not sure if kohadevbox is getting much love and attention, especially on Windows, anymore.

 

Happy to be corrected if I’m wrong but I think many people are moving / have moved to koha-testing-docker: https://gitlab.com/koha-community/koha-testing-docker.

 

The documentation could use a bit of work but you can update the KOHA_IMAGE variable to pick different images available from https://hub.docker.com/r/koha/koha-testing/tags (I actually just noticed that this moment). My guess is “master” is for stretch since there are master-jessie and master-buster available as well.

 

Personally, I use Docker Desktop on Windows, and I find mounting a volume with my Git can be painful, so I actually just created a named volume (within the Docker Desktop VM) and keep my Git clone there. That way it’s just all Linux all the time.

 

Alas, I deleted my last kohadevbox recently, so can’t help you on that one, I’m afraid.

 

David Cook

Systems Librarian

Prosentient Systems

72/330 Wattle St

Ultimo, NSW 2007

Australia

 

Office: 02 9212 0899

Direct: 02 8005 0595

 

From: Koha-devel <[hidden email]> On Behalf Of Indranil Das Gupta
Sent: Sunday, 2 February 2020 7:07 PM
To: Koha-devel <[hidden email]>
Subject: [Koha-devel] Trouble in setting up kohadevbox on Win10 prof

 

Hi all,

 

I'm trying to setup kohadevbox on a Windows 10 prof laptop. I'm going after stretch64 

 

Things I've done so far:

1. I had to switch the distribution to https://app.vagrantup.com/digital-port/boxes/debian-stretch64 because otherwise I was hitting the missing linux-headers for vbox guest additions.

 

2. Ran SMB=1 SKIP_WEBINSTALLER=1 CREATE_ADMIN_USER=1 LOCAL_ANSIBLE=1 SYNC_REPO="/home/vagrant/kohaclone" vagrant up

 

3. I've the VM created, can ssh into it both as `vagrant ssh` as well as via putty

 

4. But no cheese when i try to access http://localhost:8081 either inside the VM or from my host box

 

5. the .deb installation did go through, because there is /usr/share/koha and the koha-* commands are accessible e.g. koha-list. koha-passwd so package got installed.

 

6. /home/vagrant/kohaclone is empty and that I guess is the root of my problems because the installation has gotten gitified and there is nothing there at the moment.

 

7. I'm now manually doing a `git clone http://git.koha-community.org/koha.git kohaclone` in /home/vagrant to see if that makes a difference.

 

My question: kohadevbox README.md says - "A clone of the official Koha Git repo, or a NFS-mounted git repository from your host machine." 

 

So what am I missing here? Cluesticks / brickbats welcome... and expected :-)

thanks

 

--
Indranil Das Gupta
L2C2 Technologies

Phone : +91-98300-20971

WWW : http://www.l2c2.co.in
Blog    : http://blog.l2c2.co.in
IRC     : indradg on irc://irc.freenode.net
Twitter : indradg


_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

signature.asc (495 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Trouble in setting up kohadevbox on Win10 prof

Carlos Lopez
In reply to this post by Indranil Das Gupta-3

Hi Indranil

 

I’ve never tried to do this so please don’t take it as expert advice.

 

What I would do would be (from the VM) to check whether you have a firewalld rule to allow access to port 8081, and if you’re already allowing access to that port to see whether Apache is installed and working properly (and while you’re at it you might see whether MySQL/MariaDB is installed and working properly as well).

 

With kind regards from the Dalton McCaughey Library Team

 

Carlos Lopez

 

Dalton McCaughey Library | 29 College Crescent, Parkville, VICTORIA 3052

Ph: 03 9340 8888 ext.1 | [hidden email] | library.dmlibrary.org.au

 

From: Koha-devel <[hidden email]> On Behalf Of Indranil Das Gupta
Sent: Sunday, 2 February 2020 7:07 PM
To: Koha-devel <[hidden email]>
Subject: [Koha-devel] Trouble in setting up kohadevbox on Win10 prof

 

Hi all,

 

I'm trying to setup kohadevbox on a Windows 10 prof laptop. I'm going after stretch64 

 

Things I've done so far:

1. I had to switch the distribution to https://app.vagrantup.com/digital-port/boxes/debian-stretch64 because otherwise I was hitting the missing linux-headers for vbox guest additions.

 

2. Ran SMB=1 SKIP_WEBINSTALLER=1 CREATE_ADMIN_USER=1 LOCAL_ANSIBLE=1 SYNC_REPO="/home/vagrant/kohaclone" vagrant up

 

3. I've the VM created, can ssh into it both as `vagrant ssh` as well as via putty

 

4. But no cheese when i try to access http://localhost:8081 either inside the VM or from my host box

 

5. the .deb installation did go through, because there is /usr/share/koha and the koha-* commands are accessible e.g. koha-list. koha-passwd so package got installed.

 

6. /home/vagrant/kohaclone is empty and that I guess is the root of my problems because the installation has gotten gitified and there is nothing there at the moment.

 

7. I'm now manually doing a `git clone http://git.koha-community.org/koha.git kohaclone` in /home/vagrant to see if that makes a difference.

 

My question: kohadevbox README.md says - "A clone of the official Koha Git repo, or a NFS-mounted git repository from your host machine." 

 

So what am I missing here? Cluesticks / brickbats welcome... and expected :-)

thanks

 

--
Indranil Das Gupta
L2C2 Technologies

Phone : +91-98300-20971

WWW : http://www.l2c2.co.in
Blog    : http://blog.l2c2.co.in
IRC     : indradg on irc://irc.freenode.net
Twitter : indradg


Report this message as spam  
 


_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
Reply | Threaded
Open this post in threaded view
|

Re: Trouble in setting up kohadevbox on Win10 prof

Jonathan Druart
In reply to this post by Indranil Das Gupta-3
Hi Indranil,

On `vagrant up` you need to set SYNC_REPO to a path pointing to the Koha src.
You set "/home/vagrant/kohaclone", which does not seem correct.
That must be something like /home/$USER/kohaclone (replace that with a
windows path)

Cheers,
Jonathan

Le dim. 2 févr. 2020 à 09:06, Indranil Das Gupta <[hidden email]> a écrit :

>
> Hi all,
>
> I'm trying to setup kohadevbox on a Windows 10 prof laptop. I'm going after stretch64
>
> Things I've done so far:
>
> 1. I had to switch the distribution to https://app.vagrantup.com/digital-port/boxes/debian-stretch64 because otherwise I was hitting the missing linux-headers for vbox guest additions.
>
> 2. Ran SMB=1 SKIP_WEBINSTALLER=1 CREATE_ADMIN_USER=1 LOCAL_ANSIBLE=1 SYNC_REPO="/home/vagrant/kohaclone" vagrant up
>
> 3. I've the VM created, can ssh into it both as `vagrant ssh` as well as via putty
>
> 4. But no cheese when i try to access http://localhost:8081 either inside the VM or from my host box
>
> 5. the .deb installation did go through, because there is /usr/share/koha and the koha-* commands are accessible e.g. koha-list. koha-passwd so package got installed.
>
> 6. /home/vagrant/kohaclone is empty and that I guess is the root of my problems because the installation has gotten gitified and there is nothing there at the moment.
>
> 7. I'm now manually doing a `git clone http://git.koha-community.org/koha.git kohaclone` in /home/vagrant to see if that makes a difference.
>
> My question: kohadevbox README.md says - "A clone of the official Koha Git repo, or a NFS-mounted git repository from your host machine."
>
> So what am I missing here? Cluesticks / brickbats welcome... and expected :-)
>
> thanks
>
> --
> Indranil Das Gupta
> L2C2 Technologies
>
> Phone : +91-98300-20971
> WWW : http://www.l2c2.co.in
> Blog    : http://blog.l2c2.co.in
> IRC     : indradg on irc://irc.freenode.net
> Twitter : indradg
> _______________________________________________
> Koha-devel mailing list
> [hidden email]
> https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
> website : http://www.koha-community.org/
> git : http://git.koha-community.org/
> bugs : http://bugs.koha-community.org/
_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
Reply | Threaded
Open this post in threaded view
|

Re: Trouble in setting up kohadevbox on Win10 prof

Owen Leonard-4
In reply to this post by Indranil Das Gupta-3
I used koha-testing-docker on Windows 10 for a while and then it
stopped working for me altogether:

https://gitlab.com/koha-community/koha-testing-docker/issues/140

> 1. I had to switch the distribution to https://app.vagrantup.com/digital-port/boxes/debian-stretch64
> because otherwise I was hitting the missing linux-headers for vbox guest additions.

I switched back to kohadevbox and got it working after some wrangling,
but a few days ago it stopped working too. Now I'm seeing what I think
you're seeing too:

E: Unable to locate package linux-headers-4.9.0-9-amd64
E: Couldn't find any package by glob 'linux-headers-4.9.0-9-amd64'
E: Couldn't find any package by regex 'linux-headers-4.9.0-9-amd64'

I should have kept better notes about how I got my devbox working
before, but it's confusing that it would simply stop working.

 -- Owen

--
Web Developer
Athens County Public Libraries
(740) 737-6006
https://www.myacpl.org
_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
Reply | Threaded
Open this post in threaded view
|

Re: Trouble in setting up kohadevbox on Win10 prof

Owen Leonard-4
Looks like this was the solution I used before. Thanks to whichever
person or search engine helped me with it. Sorry I don't remember. I
know I didn't come up with it myself.

Running this shell script worked for me today:

#! /bin/sh
export FIRST_RUN='true'
vagrant up --no-provision
vagrant ssh -c 'sudo apt-get update'
vagrant ssh -c 'sudo apt-get upgrade'
vagrant ssh -c 'sudo apt-get install -y build-essential
linux-headers-amd64 linux-image-amd64 python-apt python-pip'
vagrant halt
export FIRST_RUN='false'
vagrant up

I hope that help,

 -- Owen

--
Web Developer
Athens County Public Libraries
(740) 737-6006
https://www.myacpl.org
_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
Reply | Threaded
Open this post in threaded view
|

Re: Trouble in setting up kohadevbox on Win10 prof

Mark Tompsett
In reply to this post by Indranil Das Gupta-3
Greetings,

My virtualbox didn’t play nice with Hyper-V. And various windows features
keep turning it back on, GRRRR!

Hit the Windows Key and type “windows features” Hit the Windows Key + W
combo to bring up the Windows Settings panel of the Start Screen. Click on
Turn Windows features on or off. When the Turn Windows features on or off
dialog appears, look for Hyper-V and deselect it. Click OK. Restart your
computer when prompted.

dism.exe /Online /Disable-Feature:Microsoft-Hyper-V

dism.exe /Online /Disable-Feature:Microsoft-Hyper-V /all
Restart your computer.

bcdedit /set hypervisorlaunchtype off
Restart your computer

After that, had some issues as my virtualbox, git bash, and vagrant were out
of date. So updated those.

Then I was lazy: vagrant up
It bombed, because of linux-headers something.

vagrant ssh
sudo apt install linux-headers<tab and find the right one>
exit
vagrant halt
vagrant up

It then correctly provisioned.

So, while Owen's shared script may be valid, I'm not sure it is necessary to
get too detailed.
Also, Jonathan Druart made a good point about the SYNC_REPO path being your
local windows path, not the one on the VM.

GPML,
Mark Tompsett

_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/
Reply | Threaded
Open this post in threaded view
|

Re: Trouble in setting up kohadevbox on Win10 prof

dcook
In reply to this post by Owen Leonard-4
Damn, sorry to hear that. I have some things to say on that topic, but I'll add them to the Gitlab issue.

David Cook
Systems Librarian
Prosentient Systems
72/330 Wattle St
Ultimo, NSW 2007
Australia

Office: 02 9212 0899
Direct: 02 8005 0595

-----Original Message-----
From: Koha-devel <[hidden email]> On Behalf Of Owen Leonard
Sent: Tuesday, 4 February 2020 12:42 AM
To: Koha-devel <[hidden email]>
Subject: Re: [Koha-devel] Trouble in setting up kohadevbox on Win10 prof

I used koha-testing-docker on Windows 10 for a while and then it stopped working for me altogether:

https://gitlab.com/koha-community/koha-testing-docker/issues/140

> 1. I had to switch the distribution to
> https://app.vagrantup.com/digital-port/boxes/debian-stretch64
> because otherwise I was hitting the missing linux-headers for vbox guest additions.

I switched back to kohadevbox and got it working after some wrangling, but a few days ago it stopped working too. Now I'm seeing what I think you're seeing too:

E: Unable to locate package linux-headers-4.9.0-9-amd64
E: Couldn't find any package by glob 'linux-headers-4.9.0-9-amd64'
E: Couldn't find any package by regex 'linux-headers-4.9.0-9-amd64'

I should have kept better notes about how I got my devbox working before, but it's confusing that it would simply stop working.

 -- Owen

--
Web Developer
Athens County Public Libraries
(740) 737-6006
https://www.myacpl.org
_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/ git : http://git.koha-community.org/ bugs : http://bugs.koha-community.org/


_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

signature.asc (495 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Trouble in setting up kohadevbox on Win10 prof

dcook
By the way, everyone, I think I've demonstrated on https://gitlab.com/koha-community/koha-testing-docker/issues/140 how to get koha-testing-docker working again, if you're having any issues with it.

David Cook
Systems Librarian
Prosentient Systems
72/330 Wattle St
Ultimo, NSW 2007
Australia

Office: 02 9212 0899
Direct: 02 8005 0595

-----Original Message-----
From: Koha-devel <[hidden email]> On Behalf Of [hidden email]
Sent: Tuesday, 4 February 2020 11:10 AM
To: 'Owen Leonard' <[hidden email]>; 'Koha-devel' <[hidden email]>
Subject: Re: [Koha-devel] Trouble in setting up kohadevbox on Win10 prof

Damn, sorry to hear that. I have some things to say on that topic, but I'll add them to the Gitlab issue.

David Cook
Systems Librarian
Prosentient Systems
72/330 Wattle St
Ultimo, NSW 2007
Australia

Office: 02 9212 0899
Direct: 02 8005 0595

-----Original Message-----
From: Koha-devel <[hidden email]> On Behalf Of Owen Leonard
Sent: Tuesday, 4 February 2020 12:42 AM
To: Koha-devel <[hidden email]>
Subject: Re: [Koha-devel] Trouble in setting up kohadevbox on Win10 prof

I used koha-testing-docker on Windows 10 for a while and then it stopped working for me altogether:

https://gitlab.com/koha-community/koha-testing-docker/issues/140

> 1. I had to switch the distribution to
> https://app.vagrantup.com/digital-port/boxes/debian-stretch64
> because otherwise I was hitting the missing linux-headers for vbox guest additions.

I switched back to kohadevbox and got it working after some wrangling, but a few days ago it stopped working too. Now I'm seeing what I think you're seeing too:

E: Unable to locate package linux-headers-4.9.0-9-amd64
E: Couldn't find any package by glob 'linux-headers-4.9.0-9-amd64'
E: Couldn't find any package by regex 'linux-headers-4.9.0-9-amd64'

I should have kept better notes about how I got my devbox working before, but it's confusing that it would simply stop working.

 -- Owen

--
Web Developer
Athens County Public Libraries
(740) 737-6006
https://www.myacpl.org
_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/ git : http://git.koha-community.org/ bugs : http://bugs.koha-community.org/



_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

signature.asc (495 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Trouble in setting up kohadevbox on Win10 prof

dcook
In reply to this post by Mark Tompsett
Yeah, Virtualbox/VMware can't be used at the same time as Hyper-V. Theoretically, the latest Virtualbox can use Hyper-V as a backend, but I couldn't get it to work in practice.

Personally, I've completely moved away from Virtualbox and over to Hyper-V. Docker Desktop uses Hyper-V out of the box, and I was able to get GNS3 working with Hyper-V, so I'm pretty content.

For what it's worth, Windows users don't have to use "Docker Desktop" and could instead create a Linux VM in Virtualbox and run Docker there instead. Docker Desktop is just more Windows user friendly.  

(Of course, in the next few months, we might get WSL 2 on Windows 10, which will include a real Linux kernel in a thinner virtualization layer, which would allow people to run Docker on Windows without the full Hyper-V VM, but I digress. I'll be exploring that more once it's officially released.)

David Cook
Systems Librarian
Prosentient Systems
72/330 Wattle St
Ultimo, NSW 2007
Australia

Office: 02 9212 0899
Direct: 02 8005 0595

-----Original Message-----
From: Koha-devel <[hidden email]> On Behalf Of Mark Tompsett
Sent: Tuesday, 4 February 2020 3:03 AM
To: Koha-devel <[hidden email]>
Subject: Re: [Koha-devel] Trouble in setting up kohadevbox on Win10 prof

Greetings,

My virtualbox didn’t play nice with Hyper-V. And various windows features keep turning it back on, GRRRR!

Hit the Windows Key and type “windows features” Hit the Windows Key + W combo to bring up the Windows Settings panel of the Start Screen. Click on Turn Windows features on or off. When the Turn Windows features on or off dialog appears, look for Hyper-V and deselect it. Click OK. Restart your computer when prompted.

dism.exe /Online /Disable-Feature:Microsoft-Hyper-V

dism.exe /Online /Disable-Feature:Microsoft-Hyper-V /all Restart your computer.

bcdedit /set hypervisorlaunchtype off
Restart your computer

After that, had some issues as my virtualbox, git bash, and vagrant were out of date. So updated those.

Then I was lazy: vagrant up
It bombed, because of linux-headers something.

vagrant ssh
sudo apt install linux-headers<tab and find the right one> exit vagrant halt vagrant up

It then correctly provisioned.

So, while Owen's shared script may be valid, I'm not sure it is necessary to get too detailed.
Also, Jonathan Druart made a good point about the SYNC_REPO path being your local windows path, not the one on the VM.

GPML,
Mark Tompsett

_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/ git : http://git.koha-community.org/ bugs : http://bugs.koha-community.org/


_______________________________________________
Koha-devel mailing list
[hidden email]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

signature.asc (495 bytes) Download Attachment