Koha zebra index issue

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Koha zebra index issue

LISolutions

Dear All

Hope you are doing well

I've installed koha 3.004 at Debian Lenny.  Installation was smooth without any error.  When I add some record the record is saving in MySQL but I got no result found message in OPAC and Intranet.  I tried several time rebuild_zebra.pl -r -b -a command.  I've also tried zebraquedaemon but no result.  what should i do?

Ata


_______________________________________________
Koha mailing list
[hidden email]
http://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Koha zebra index issue

john smith-108
Hi

If the environment variable is correctly set you should have exactly the same as below

[root@koha31 ~]# export PERL5LIB=/usr/share/koha/lib

[root@koha31 ~]# echo $PERL5LIB

/usr/share/koha/lib

[root@koha31 ~]# perl -e "print \"\$INC[0]\\n\";"

/usr/share/koha/lib

 and try to export KOHA_CONF

and rebuild zebra again

 

hope to fix it


John Smith
International Library of Southiana
IT Supports



 


From: [hidden email]
Date: Wed, 11 Nov 2009 17:07:30 +0500
To: [hidden email]
Subject: [Koha] Koha zebra index issue


Dear All

Hope you are doing well

I've installed koha 3.004 at Debian Lenny.  Installation was smooth without any error.  When I add some record the record is saving in MySQL but I got no result found message in OPAC and Intranet.  I tried several time rebuild_zebra.pl -r -b -a command.  I've also tried zebraquedaemon but no result.  what should i do?

Ata



Windows Live: Friends get your Flickr, Yelp, and Digg updates when they e-mail you.
_______________________________________________
Koha mailing list
[hidden email]
http://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Koha zebra index issue

LISolutions
I checked all variable path and rebuil zebra with -b -r -a swithes but no result.  Then i changed it to noZebra mode and run rebuild_nozebra.pl -s after that i am finding the results from my opac.  why zebra is not working with it...
I've same configuration on my hp laptop with same version of koha and lenny and zebra indexing is working there... it is strange why different behaviour on diff machines

Regards,
Ata


On Wed, Nov 11, 2009 at 5:29 PM, john smith <[hidden email]> wrote:
Hi

If the environment variable is correctly set you should have exactly the same as below

[root@koha31 ~]# export PERL5LIB=/usr/share/koha/lib

[root@koha31 ~]# echo $PERL5LIB

/usr/share/koha/lib

[root@koha31 ~]# perl -e "print \"\$INC[0]\\n\";"

/usr/share/koha/lib

 and try to export KOHA_CONF

and rebuild zebra again

 

hope to fix it


John Smith
International Library of Southiana
IT Supports



 


From: [hidden email]
Date: Wed, 11 Nov 2009 17:07:30 +0500
To: [hidden email]


Subject: [Koha] Koha zebra index issue


Dear All

Hope you are doing well

I've installed koha 3.004 at Debian Lenny.  Installation was smooth without any error.  When I add some record the record is saving in MySQL but I got no result found message in OPAC and Intranet.  I tried several time rebuild_zebra.pl -r -b -a command.  I've also tried zebraquedaemon but no result.  what should i do?

Ata



Windows Live: Friends get your Flickr, Yelp, and Digg updates when they e-mail you.


_______________________________________________
Koha mailing list
[hidden email]
http://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Koha zebra index issue

Biblioteca Casa Balthasar
Ata,

Is rebuild_zebra.pl producing any error output?  What do your zebra logs look like in /var/koha/?

In any case, you might want to check and see if it isn't an issue of permissions.  That is to say, what user do you use to run rebuild_zebra.pl and to whom belong the folders and files that contain the index files (for us that's /var/lib/koha/zebradb and its various subfolders)?  If you're using the zebra daemon, under what user does it run?  

Best,
Patrick Redmon

2009/11/14 Ata ur Rehman <[hidden email]>
I checked all variable path and rebuil zebra with -b -r -a swithes but no result.  Then i changed it to noZebra mode and run rebuild_nozebra.pl -s after that i am finding the results from my opac.  why zebra is not working with it...
I've same configuration on my hp laptop with same version of koha and lenny and zebra indexing is working there... it is strange why different behaviour on diff machines

Regards,
Ata



On Wed, Nov 11, 2009 at 5:29 PM, john smith <[hidden email]> wrote:
Hi

If the environment variable is correctly set you should have exactly the same as below

[root@koha31 ~]# export PERL5LIB=/usr/share/koha/lib

[root@koha31 ~]# echo $PERL5LIB

/usr/share/koha/lib

[root@koha31 ~]# perl -e "print \"\$INC[0]\\n\";"

/usr/share/koha/lib

 and try to export KOHA_CONF

and rebuild zebra again

 

hope to fix it


John Smith
International Library of Southiana
IT Supports



 


From: [hidden email]
Date: Wed, 11 Nov 2009 17:07:30 +0500
To: [hidden email]


Subject: [Koha] Koha zebra index issue


Dear All

Hope you are doing well

I've installed koha 3.004 at Debian Lenny.  Installation was smooth without any error.  When I add some record the record is saving in MySQL but I got no result found message in OPAC and Intranet.  I tried several time rebuild_zebra.pl -r -b -a command.  I've also tried zebraquedaemon but no result.  what should i do?

Ata



Windows Live: Friends get your Flickr, Yelp, and Digg updates when they e-mail you.


_______________________________________________
Koha mailing list
[hidden email]
http://lists.katipo.co.nz/mailman/listinfo/koha



_______________________________________________
Koha mailing list
[hidden email]
http://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Koha zebra index issue

Chris Nighswonger
In reply to this post by LISolutions
Hi Ata,

2009/11/14 Ata ur Rehman <[hidden email]>:
> I checked all variable path and rebuil zebra with -b -r -a swithes but no
> result.  Then i changed it to noZebra mode and run rebuild_nozebra.pl -s
> after that i am finding the results from my opac.  why zebra is not working
> with it...
> I've same configuration on my hp laptop with same version of koha and lenny
> and zebra indexing is working there... it is strange why different behaviour
> on diff machines
>

Try 'perl rebuild_zebra.pl -b -r -v' and post the output.

Kind Regards,
Chris
_______________________________________________
Koha mailing list
[hidden email]
http://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Koha zebra index issue

LISolutions
The output is as given below:


/usr/share/koha/bin/migration_tools# ./rebuild_zebra.pl -a -r -b -v
Zebra configuration information
================================
Zebra biblio directory      = /var/lib/koha/zebradb/biblios
Zebra authorities directory = /var/lib/koha/zebradb/authorities
Koha directory              = /usr/share/koha/intranet/cgi-bin
BIBLIONUMBER in :     999$c
BIBLIOITEMNUMBER in : 999$d
================================
====================
exporting authority
====================

Records exported: 0
====================
REINDEXING zebra
====================
====================
exporting biblio
====================
1.
Records exported: 2
====================
REINDEXING zebra
====================
13:31:01-15/12 zebraidx(3644) [log] zebra_start 2.0.36 /etc/koha/zebradb/zebra-biblios.cfg
13:31:01-15/12 zebraidx(3644) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-grs-regx.so
13:31:01-15/12 zebraidx(3644) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-text.so
13:31:01-15/12 zebraidx(3644) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-alvis.so
13:31:01-15/12 zebraidx(3644) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-grs-xml.so
13:31:01-15/12 zebraidx(3644) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-dom.so
13:31:01-15/12 zebraidx(3644) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-grs-marc.so
13:31:01-15/12 zebraidx(3644) [log] enabling shadow spec=/var/lib/koha/zebradb/biblios/shadow:4G
13:31:01-15/12 zebraidx(3644) [log] cache_fname = /var/lib/koha/zebradb/biblios/shadow/cache
13:31:01-15/12 zebraidx(3644) [log] zebra_stop: 0.00 0.00 0.00
13:31:01-15/12 zebraidx(3645) [log] zebra_start 2.0.36 /etc/koha/zebradb/zebra-biblios.cfg
13:31:01-15/12 zebraidx(3645) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-grs-regx.so
13:31:01-15/12 zebraidx(3645) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-text.so
13:31:01-15/12 zebraidx(3645) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-alvis.so
13:31:01-15/12 zebraidx(3645) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-grs-xml.so
13:31:01-15/12 zebraidx(3645) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-dom.so
13:31:01-15/12 zebraidx(3645) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-grs-marc.so
13:31:01-15/12 zebraidx(3645) [log] enabling shadow spec=/var/lib/koha/zebradb/biblios/shadow:4G
13:31:01-15/12 zebraidx(3645) [log] cache_fname = /var/lib/koha/zebradb/biblios/shadow/cache
13:31:01-15/12 zebraidx(3645) [log] dir /tmp/gNC3Yjnz1T/biblio
13:31:01-15/12 zebraidx(3645) [log] add grs.marcxml.record /tmp/gNC3Yjnz1T/biblio/exported_records 0
13:31:01-15/12 zebraidx(3645) [log] add grs.marcxml.record /tmp/gNC3Yjnz1T/biblio/exported_records 867
13:31:01-15/12 zebraidx(3645) [log] Iterations: isam/dict 1878/569
13:31:01-15/12 zebraidx(3645) [log] Dict: inserts/updates/deletions: 569/0/0
13:31:01-15/12 zebraidx(3645) [log] Records: 2 i/u/d 2/0/0
13:31:01-15/12 zebraidx(3645) [log] zebra_stop: 0.03 0.02 0.00
13:31:01-15/12 zebraidx(3648) [log] zebra_start 2.0.36 /etc/koha/zebradb/zebra-biblios.cfg
13:31:01-15/12 zebraidx(3648) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-grs-regx.so
13:31:01-15/12 zebraidx(3648) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-text.so
13:31:01-15/12 zebraidx(3648) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-alvis.so
13:31:01-15/12 zebraidx(3648) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-grs-xml.so
13:31:01-15/12 zebraidx(3648) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-dom.so
13:31:01-15/12 zebraidx(3648) [log] Loaded filter module /usr/lib/idzebra-2.0/modules/mod-grs-marc.so
13:31:01-15/12 zebraidx(3648) [log] enabling shadow spec=/var/lib/koha/zebradb/biblios/shadow:4G
13:31:01-15/12 zebraidx(3648) [log] cache_fname = /var/lib/koha/zebradb/biblios/shadow/cache
13:31:01-15/12 zebraidx(3648) [log] zebra_stop: 0.02 0.00 0.00
====================
CLEANING
====================
/usr/share/koha/bin/migration_tools#




Regards,

Ata



On Sat, Nov 14, 2009 at 10:20 PM, Chris Nighswonger <[hidden email]> wrote:
Hi Ata,

2009/11/14 Ata ur Rehman <[hidden email]>:
> I checked all variable path and rebuil zebra with -b -r -a swithes but no
> result.  Then i changed it to noZebra mode and run rebuild_nozebra.pl -s
> after that i am finding the results from my opac.  why zebra is not working
> with it...
> I've same configuration on my hp laptop with same version of koha and lenny
> and zebra indexing is working there... it is strange why different behaviour
> on diff machines
>

Try 'perl rebuild_zebra.pl -b -r -v' and post the output.

Kind Regards,
Chris


_______________________________________________
Koha mailing list
[hidden email]
http://lists.katipo.co.nz/mailman/listinfo/koha