Koha 17.11.01 released

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Koha 17.11.01 released

Jonathan Druart
The Koha community is proud to announce the release of Koha 17.11.01.

This is a maintenance release including a few security fixes.

The full release notes are available at
https://koha-community.org/koha-17-11-01-release

Packages are also available.

Regards,
Jonathan (for Nick)
_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Koha 17.11.01 released

Bruce A. Metcalf-3
On 01/03/2018 12:25 PM, Jonathan Druart wrote:

> The Koha community is proud to announce the release of Koha  > 17.11.01. Packages are also available.

When I attempt to upgrade using apt-get, the system proposes to remove
koha-common, but not to replace or upgrade it. This is not how previous
upgrades have been done. Is this correct?

Koha 17.05.05 installed via packages under Debian Squeeze.

Regards,
/ Bruce /
Bruce A. Metcalf, FAS
Augustan Society Library


_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Koha 17.11.01 released

Chris Cormack-7
Hi Bruce

That usually means an unmet dependency. Definitely don't remove it. I'll look into it soon and see if I can spot what the issue is

Chris

On January 5, 2018 5:35:09 AM GMT+13:00, "Bruce A. Metcalf" <[hidden email]> wrote:

>On 01/03/2018 12:25 PM, Jonathan Druart wrote:
>
>> The Koha community is proud to announce the release of Koha  >
>17.11.01. Packages are also available.
>
>When I attempt to upgrade using apt-get, the system proposes to remove
>koha-common, but not to replace or upgrade it. This is not how previous
>
>upgrades have been done. Is this correct?
>
>Koha 17.05.05 installed via packages under Debian Squeeze.
>
>Regards,
>/ Bruce /
>Bruce A. Metcalf, FAS
>Augustan Society Library
>
>
>_______________________________________________
>Koha mailing list  http://koha-community.org
>[hidden email]
>https://lists.katipo.co.nz/mailman/listinfo/koha

--
Sent from my Android device with K-9 Mail. Please excuse my brevity.
_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Koha 17.11.01 released

Chris Cormack-7
* Chris Cormack ([hidden email]) wrote:
>Hi Bruce
>
>That usually means an unmet dependency. Definitely don't remove it. I'll look into it soon and see if I can spot what the issue is
>
>Chris

Hmm, I just tried at work and the 17.11.00 to 17.11.01 worked fine

Can you paste exactly what it is saying when you upgrade (don't choose
yes to remove though)

Chris

>
>On January 5, 2018 5:35:09 AM GMT+13:00, "Bruce A. Metcalf" <[hidden email]> wrote:
>>On 01/03/2018 12:25 PM, Jonathan Druart wrote:
>>
>>> The Koha community is proud to announce the release of Koha  >
>>17.11.01. Packages are also available.
>>
>>When I attempt to upgrade using apt-get, the system proposes to remove
>>koha-common, but not to replace or upgrade it. This is not how previous
>>
>>upgrades have been done. Is this correct?
>>
>>Koha 17.05.05 installed via packages under Debian Squeeze.
>>
>>Regards,
>>/ Bruce /
>>Bruce A. Metcalf, FAS
>>Augustan Society Library
>>
>>
>>_______________________________________________
>>Koha mailing list  http://koha-community.org
>>[hidden email]
>>https://lists.katipo.co.nz/mailman/listinfo/koha
>
>--
>Sent from my Android device with K-9 Mail. Please excuse my brevity.
>_______________________________________________
>Koha mailing list  http://koha-community.org
>[hidden email]
>https://lists.katipo.co.nz/mailman/listinfo/koha
--
Chris Cormack
Catalyst IT Ltd.
+64 4 803 2238
PO Box 11-053, Manners St, Wellington 6142, New Zealand

_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Koha 17.11.01 released

Hector Gonzalez
In reply to this post by Chris Cormack-7
Try apt-get dist-upgrade, there is a new dependency in 17.11 that was
not there with 17.05. If you don't want to dist-upgrade, you can answer
no to the prompt, but it will tell you what is blocking the upgrade.

You may then install the dependency (in my case it was
libmojolicious-plugin-openapi-perl ) and then apt-get upgrade will proceed.


On 01/04/2018 12:26 PM, Chris Cormack wrote:

> Hi Bruce
>
> That usually means an unmet dependency. Definitely don't remove it. I'll look into it soon and see if I can spot what the issue is
>
> Chris
>
> On January 5, 2018 5:35:09 AM GMT+13:00, "Bruce A. Metcalf" <[hidden email]> wrote:
>> On 01/03/2018 12:25 PM, Jonathan Druart wrote:
>>
>>> The Koha community is proud to announce the release of Koha  >
>> 17.11.01. Packages are also available.
>>
>> When I attempt to upgrade using apt-get, the system proposes to remove
>> koha-common, but not to replace or upgrade it. This is not how previous
>>
>> upgrades have been done. Is this correct?
>>
>> Koha 17.05.05 installed via packages under Debian Squeeze.
>>
>> Regards,
>> / Bruce /
>> Bruce A. Metcalf, FAS
>> Augustan Society Library
>>
>>
>> _______________________________________________
>> Koha mailing list  http://koha-community.org
>> [hidden email]
>> https://lists.katipo.co.nz/mailman/listinfo/koha

--
Héctor González
[hidden email]

_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Koha 17.11.01 released

Liz Rea-3
In reply to this post by Bruce A. Metcalf-3
Hi Bruce,

If you are really on Debian Squeeze (6.0), that's super old Debian and
Koha 17.11 won't work with that - as you noticed some of the
dependencies aren't there for that old a version of Debian.

This upgrade will be a slightly bigger project for you, as you'll need
to upgrade your OS before you can upgrade Koha. You should probably do
that anyway, sooner rather than later. Debian is now up to version 9,
code name Stretch.

Cheers,
Liz Rea

Catalyst IT


On 05/01/18 05:35, Bruce A. Metcalf wrote:

> On 01/03/2018 12:25 PM, Jonathan Druart wrote:
>
>> The Koha community is proud to announce the release of Koha  >
>> 17.11.01. Packages are also available.
>
> When I attempt to upgrade using apt-get, the system proposes to remove
> koha-common, but not to replace or upgrade it. This is not how
> previous upgrades have been done. Is this correct?
>
> Koha 17.05.05 installed via packages under Debian Squeeze.
>
> Regards,
> / Bruce /
> Bruce A. Metcalf, FAS
> Augustan Society Library
>
>
> _______________________________________________
> Koha mailing list  http://koha-community.org
> [hidden email]
> https://lists.katipo.co.nz/mailman/listinfo/koha

--
--
Liz Rea
Catalyst.Net Limited
Level 6, Catalyst House,
150 Willis Street, Wellington.
P.O Box 11053, Manners Street,
Wellington 6142
04 803 2265

GPG: B149 A443 6B01 7386 C2C7 F481 B6c2 A49D 3726 38B7

_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Koha 17.11.01 released

Bruce A. Metcalf
In reply to this post by Chris Cormack-7
On 01/04/2018 01:55 PM, Chris Cormack wrote:
> * Chris Cormack ([hidden email]) wrote:
>> That usually means an unmet dependency. Definitely don't remove it.
>> I'll look into it soon and see if I can spot what the issue is
>
> Hmm, I just tried at work and the 17.11.00 to 17.11.01 worked fine
>
> Can you paste exactly what it is saying when you upgrade (don't choose
> yes to remove though)

This system has just had "apt-get update && apt-get upgrade" run, with
no new packages suggested.
When I try to upgrade:

======
root# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... The following packages were automatically
installed and are no longer required:
  at autopoint daemon docbook-xml docbook-xsl gettext idzebra-2.0
idzebra-2.0-common idzebra-2.0-doc idzebra-2.0-utils
libalgorithm-checkdigits-perl libanyevent-http-perl libanyevent-perl
libappconfig-perl libarchive-zip-perl libauthen-cas-client-perl
libbarcode-code128-perl libbiblio-endnotestyle-perl libbit-vector-perl
libbusiness-isbn-data-perl libbusiness-isbn-perl libcache-fastmmap-perl
libcache-memcached-fast-perl libcache-memcached-perl libcache-perl
libcarp-assert-more-perl libcarp-assert-perl libcarp-clan-perl
libcgi-compile-perl libcgi-emulate-psgi-perl
libcgi-session-driver-memcached-perl libcgi-session-perl
libcgi-session-serialize-yaml-perl libclass-accessor-chained-perl
libclass-accessor-grouped-perl libclass-accessor-perl
libclass-adapter-perl libclass-c3-componentised-perl
libclass-data-inheritable-perl libclass-factory-util-perl
libclass-makemethods-perl libclass-mix-perl libclass-returnvalue-perl
libclass-singleton-perl libclass-unload-perl libcontext-preserve-perl
libconvert-basen-perl libcrypt-eksblowfish-perl libcrypt-gcrypt-perl
libdata-dumper-concise-perl libdata-ical-perl libdata-page-perl
libdate-calc-perl libdate-manip-perl libdatetime-event-ical-perl
libdatetime-event-recurrence-perl libdatetime-format-builder-perl
libdatetime-format-ical-perl libdatetime-format-mail-perl
libdatetime-format-mysql-perl libdatetime-format-strptime-perl
libdatetime-format-w3cdtf-perl libdatetime-locale-perl libdatetime-perl
libdatetime-set-perl libdatetime-timezone-perl libdbd-mock-perl
libdbd-sqlite2-perl libdbix-class-perl libdbix-class-schema-loader-perl
libdbix-runsql-perl libdevel-cover-perl libdevel-stacktrace-ashtml-perl
libdevel-symdump-perl libemail-abstract-perl libemail-date-perl
libemail-simple-perl libemail-valid-perl libexception-class-perl
libfile-nfslock-perl libfile-pushd-perl libfile-sharedir-perl
libfile-slurp-perl libfilesys-notify-simple-perl libfont-ttf-perl
libgd-barcode-perl libgraph-perl libgraphics-colornames-perl
libgraphics-magick-perl libgraphicsmagick3 libgraphviz-perl
libgravatar-url-perl libhash-multivalue-perl libheap-perl
libhtml-scrubber-perl libhtml-tidy-perl libhttp-body-perl
libhttp-oai-perl libhttp-parser-xs-perl libhttp-server-simple-perl
libidzebra-2.0-0 libidzebra-2.0-dev libidzebra-2.0-mod-alvis
libidzebra-2.0-mod-dom libidzebra-2.0-mod-grs-marc
libidzebra-2.0-mod-grs-regx libidzebra-2.0-mod-grs-xml
libidzebra-2.0-mod-text libidzebra-2.0-modules libimage-size-perl
libio-multiplex-perl libio-pty-perl libipc-run-perl
libipc-shareable-perl libjcode-pm-perl libjson-validator-perl
liblibrary-callnumber-lc-perl liblingua-ispell-perl
liblingua-stem-snowball-perl liblocale-currency-format-perl
liblocale-maketext-lexicon-perl liblocale-po-perl liblog-dispatch-perl
liblog-log4perl-perl libmail-sendmail-perl libmarc-charset-perl
libmarc-record-perl libmarc-xml-perl libmath-base36-perl
libmodern-perl-perl libmodule-bundled-files-perl libmodule-find-perl
libmodule-refresh-perl libmojolicious-plugin-openapi-perl
libnet-cidr-perl libnet-domain-tld-perl libnet-server-perl
libnet-sftp-foreign-perl libnet-z3950-zoom-perl libnumber-format-perl
libole-storage-lite-perl libopenoffice-oodoc-perl
libparse-recdescent-perl libpath-class-perl libpdf-api2-perl
libpdf-api2-simple-perl libpdf-fromhtml-perl libpdf-reuse-barcode-perl
libpdf-reuse-perl libpdf-table-perl libpdf-writer-perl
libplack-middleware-reverseproxy-perl libplack-perl libpod-coverage-perl
libreadonly-perl libreadonly-xs-perl libschedule-at-perl
libset-infinite-perl libsms-send-perl libspreadsheet-parseexcel-perl
libspreadsheet-writeexcel-perl libsql-abstract-perl
libsql-translator-perl libstring-crc32-perl libstring-random-perl
libsub-uplevel-perl libswagger2-perl libtemplate-perl
libtemplate-plugin-htmltotext-perl libtemplate-plugin-json-escape-perl
libtemplate-plugin-stash-perl libtest-deep-perl libtest-longstring-perl
libtest-mockmodule-perl libtest-pod-perl libtest-sharedfork-perl
libtest-simple-perl libtest-strict-perl libtest-tcp-perl
libtest-warn-perl libtest-www-mechanize-perl libtest-yaml-valid-perl
libtext-bidi-perl libtext-csv-encoded-perl libtext-csv-perl
libtext-csv-xs-perl libtext-pdf-perl libtext-recordparser-perl
libtext-tabulardisplay-perl libtext-unaccent-perl
libtext-vfile-asdata-perl libtidy-0.99-0 libtie-ixhash-perl
libtime-fake-perl libunicode-map-perl libuniversal-can-perl
libuniversal-isa-perl libuniversal-require-perl libuuid-perl
libwww-mechanize-perl libxml-dumper-perl libxml-filter-buffertext-perl
libxml-libxslt-perl libxml-rss-perl libxml-sax-writer-perl
libxml-twig-perl libxml-writer-perl libxml-xpathengine-perl
libxml2-utils libyaz4 pwgen sgml-data starman tinymce ttf-dejavu
ttf-dejavu-core ttf-dejavu-extra unzip xmlstarlet xsltproc yaz
Use 'apt-get autoremove' to remove them.
Done
The following packages will be REMOVED:
   koha-common libtest-exception-perl libtest-mockobject-perl
The following NEW packages will be installed:
   libmojolicious-plugin-openapi-perl
The following packages have been kept back:
   libtest-simple-perl
0 upgraded, 1 newly installed, 3 to remove and 1 not upgraded.
Need to get 29.0 kB of archives.
After this operation, 439 MB disk space will be freed.
Do you want to continue? [Y/n]
======

TIA,
/ Bruce /
Bruce A. Metcalf
Augustan Society Library

_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Koha 17.11.01 released

Bruce A. Metcalf
In reply to this post by Liz Rea-3
On 01/04/2018 05:56 PM, Liz Rea wrote:

> If you are really on Debian Squeeze (6.0), that's super old Debian and
> Koha 17.11 won't work with that - as you noticed some of the
> dependencies aren't there for that old a version of Debian.
>
> This upgrade will be a slightly bigger project for you, as you'll need
> to upgrade your OS before you can upgrade Koha. You should probably do
> that anyway, sooner rather than later. Debian is now up to version 9,
> code name Stretch.

My error. I am indeed running Debian ver. 8, which appears to still be
supported.

I tend to avoid version upgrades in the OS, as one never knows what
won't be supported after, but will try that if all else fails.

Thanks,
/ Bruce /
Bruce A. Metcalf
Augustan Society Library

_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Koha 17.11.01 released

Chris Cormack-7
In reply to this post by Bruce A. Metcalf
Hi Bruce

What happens if you try

sudo apt-get install libtest-simple-perl

?

Chris

* Bruce A. Metcalf ([hidden email]) wrote:

>On 01/04/2018 01:55 PM, Chris Cormack wrote:
>>* Chris Cormack ([hidden email]) wrote:
>>>That usually means an unmet dependency. Definitely don't remove
>>>it. I'll look into it soon and see if I can spot what the issue is
>>
>>Hmm, I just tried at work and the 17.11.00 to 17.11.01 worked fine
>>
>>Can you paste exactly what it is saying when you upgrade (don't choose
>>yes to remove though)
>
>This system has just had "apt-get update && apt-get upgrade" run, with
>no new packages suggested.
>When I try to upgrade:
>
>======
>root# apt-get dist-upgrade
>Reading package lists... Done
>Building dependency tree
>Reading state information... Done
>Calculating upgrade... The following packages were automatically
>installed and are no longer required:
> at autopoint daemon docbook-xml docbook-xsl gettext idzebra-2.0
>idzebra-2.0-common idzebra-2.0-doc idzebra-2.0-utils
>libalgorithm-checkdigits-perl libanyevent-http-perl libanyevent-perl
>libappconfig-perl libarchive-zip-perl libauthen-cas-client-perl
>libbarcode-code128-perl libbiblio-endnotestyle-perl libbit-vector-perl
>libbusiness-isbn-data-perl libbusiness-isbn-perl
>libcache-fastmmap-perl libcache-memcached-fast-perl
>libcache-memcached-perl libcache-perl libcarp-assert-more-perl
>libcarp-assert-perl libcarp-clan-perl libcgi-compile-perl
>libcgi-emulate-psgi-perl libcgi-session-driver-memcached-perl
>libcgi-session-perl libcgi-session-serialize-yaml-perl
>libclass-accessor-chained-perl libclass-accessor-grouped-perl
>libclass-accessor-perl libclass-adapter-perl
>libclass-c3-componentised-perl libclass-data-inheritable-perl
>libclass-factory-util-perl libclass-makemethods-perl libclass-mix-perl
>libclass-returnvalue-perl libclass-singleton-perl libclass-unload-perl
>libcontext-preserve-perl libconvert-basen-perl
>libcrypt-eksblowfish-perl libcrypt-gcrypt-perl
>libdata-dumper-concise-perl libdata-ical-perl libdata-page-perl
>libdate-calc-perl libdate-manip-perl libdatetime-event-ical-perl
>libdatetime-event-recurrence-perl libdatetime-format-builder-perl
>libdatetime-format-ical-perl libdatetime-format-mail-perl
>libdatetime-format-mysql-perl libdatetime-format-strptime-perl
>libdatetime-format-w3cdtf-perl libdatetime-locale-perl
>libdatetime-perl libdatetime-set-perl libdatetime-timezone-perl
>libdbd-mock-perl libdbd-sqlite2-perl libdbix-class-perl
>libdbix-class-schema-loader-perl libdbix-runsql-perl
>libdevel-cover-perl libdevel-stacktrace-ashtml-perl
>libdevel-symdump-perl libemail-abstract-perl libemail-date-perl
>libemail-simple-perl libemail-valid-perl libexception-class-perl
>libfile-nfslock-perl libfile-pushd-perl libfile-sharedir-perl
>libfile-slurp-perl libfilesys-notify-simple-perl libfont-ttf-perl
>libgd-barcode-perl libgraph-perl libgraphics-colornames-perl
>libgraphics-magick-perl libgraphicsmagick3 libgraphviz-perl
>libgravatar-url-perl libhash-multivalue-perl libheap-perl
>libhtml-scrubber-perl libhtml-tidy-perl libhttp-body-perl
>libhttp-oai-perl libhttp-parser-xs-perl libhttp-server-simple-perl
>libidzebra-2.0-0 libidzebra-2.0-dev libidzebra-2.0-mod-alvis
>libidzebra-2.0-mod-dom libidzebra-2.0-mod-grs-marc
>libidzebra-2.0-mod-grs-regx libidzebra-2.0-mod-grs-xml
>libidzebra-2.0-mod-text libidzebra-2.0-modules libimage-size-perl
>libio-multiplex-perl libio-pty-perl libipc-run-perl
>libipc-shareable-perl libjcode-pm-perl libjson-validator-perl
>liblibrary-callnumber-lc-perl liblingua-ispell-perl
>liblingua-stem-snowball-perl liblocale-currency-format-perl
>liblocale-maketext-lexicon-perl liblocale-po-perl liblog-dispatch-perl
>liblog-log4perl-perl libmail-sendmail-perl libmarc-charset-perl
>libmarc-record-perl libmarc-xml-perl libmath-base36-perl
>libmodern-perl-perl libmodule-bundled-files-perl libmodule-find-perl
>libmodule-refresh-perl libmojolicious-plugin-openapi-perl
>libnet-cidr-perl libnet-domain-tld-perl libnet-server-perl
>libnet-sftp-foreign-perl libnet-z3950-zoom-perl libnumber-format-perl
>libole-storage-lite-perl libopenoffice-oodoc-perl
>libparse-recdescent-perl libpath-class-perl libpdf-api2-perl
>libpdf-api2-simple-perl libpdf-fromhtml-perl libpdf-reuse-barcode-perl
>libpdf-reuse-perl libpdf-table-perl libpdf-writer-perl
>libplack-middleware-reverseproxy-perl libplack-perl
>libpod-coverage-perl libreadonly-perl libreadonly-xs-perl
>libschedule-at-perl libset-infinite-perl libsms-send-perl
>libspreadsheet-parseexcel-perl libspreadsheet-writeexcel-perl
>libsql-abstract-perl libsql-translator-perl libstring-crc32-perl
>libstring-random-perl libsub-uplevel-perl libswagger2-perl
>libtemplate-perl libtemplate-plugin-htmltotext-perl
>libtemplate-plugin-json-escape-perl libtemplate-plugin-stash-perl
>libtest-deep-perl libtest-longstring-perl libtest-mockmodule-perl
>libtest-pod-perl libtest-sharedfork-perl libtest-simple-perl
>libtest-strict-perl libtest-tcp-perl libtest-warn-perl
>libtest-www-mechanize-perl libtest-yaml-valid-perl libtext-bidi-perl
>libtext-csv-encoded-perl libtext-csv-perl libtext-csv-xs-perl
>libtext-pdf-perl libtext-recordparser-perl libtext-tabulardisplay-perl
>libtext-unaccent-perl libtext-vfile-asdata-perl libtidy-0.99-0
>libtie-ixhash-perl libtime-fake-perl libunicode-map-perl
>libuniversal-can-perl libuniversal-isa-perl libuniversal-require-perl
>libuuid-perl libwww-mechanize-perl libxml-dumper-perl
>libxml-filter-buffertext-perl libxml-libxslt-perl libxml-rss-perl
>libxml-sax-writer-perl libxml-twig-perl libxml-writer-perl
>libxml-xpathengine-perl libxml2-utils libyaz4 pwgen sgml-data starman
>tinymce ttf-dejavu ttf-dejavu-core ttf-dejavu-extra unzip xmlstarlet
>xsltproc yaz
>Use 'apt-get autoremove' to remove them.
>Done
>The following packages will be REMOVED:
>  koha-common libtest-exception-perl libtest-mockobject-perl
>The following NEW packages will be installed:
>  libmojolicious-plugin-openapi-perl
>The following packages have been kept back:
>  libtest-simple-perl
>0 upgraded, 1 newly installed, 3 to remove and 1 not upgraded.
>Need to get 29.0 kB of archives.
>After this operation, 439 MB disk space will be freed.
>Do you want to continue? [Y/n]
>======
>
>TIA,
>/ Bruce /
>Bruce A. Metcalf
>Augustan Society Library
>
>_______________________________________________
>Koha mailing list  http://koha-community.org
>[hidden email]
>https://lists.katipo.co.nz/mailman/listinfo/koha
--
Chris Cormack
Catalyst IT Ltd.
+64 4 803 2238
PO Box 11-053, Manners St, Wellington 6142, New Zealand

_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Koha 17.11.01 released

Hector Gonzalez
In reply to this post by Bruce A. Metcalf
Try this: apt-get install koha-common

It should mark it as "to be installed", try to resolve its dependencies,
and upgrade it to the latest version.  It looks like it is marked to be
removed, and this it should be corrected.


On 01/08/2018 09:36 AM, Bruce A. Metcalf wrote:

> On 01/04/2018 01:55 PM, Chris Cormack wrote:
>> * Chris Cormack ([hidden email]) wrote:
>>> That usually means an unmet dependency. Definitely don't remove it.
>>> I'll look into it soon and see if I can spot what the issue is
>>
>> Hmm, I just tried at work and the 17.11.00 to 17.11.01 worked fine
>>
>> Can you paste exactly what it is saying when you upgrade (don't choose
>> yes to remove though)
>
> This system has just had "apt-get update && apt-get upgrade" run, with
> no new packages suggested.
> When I try to upgrade:
>
> ======
> root# apt-get dist-upgrade
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Calculating upgrade... The following packages were automatically
> installed and are no longer required:
>  at autopoint daemon docbook-xml docbook-xsl gettext idzebra-2.0
> idzebra-2.0-common idzebra-2.0-doc idzebra-2.0-utils
> libalgorithm-checkdigits-perl libanyevent-http-perl libanyevent-perl
> libappconfig-perl libarchive-zip-perl libauthen-cas-client-perl
> libbarcode-code128-perl libbiblio-endnotestyle-perl libbit-vector-perl
> libbusiness-isbn-data-perl libbusiness-isbn-perl
> libcache-fastmmap-perl libcache-memcached-fast-perl
> libcache-memcached-perl libcache-perl libcarp-assert-more-perl
> libcarp-assert-perl libcarp-clan-perl libcgi-compile-perl
> libcgi-emulate-psgi-perl libcgi-session-driver-memcached-perl
> libcgi-session-perl libcgi-session-serialize-yaml-perl
> libclass-accessor-chained-perl libclass-accessor-grouped-perl
> libclass-accessor-perl libclass-adapter-perl
> libclass-c3-componentised-perl libclass-data-inheritable-perl
> libclass-factory-util-perl libclass-makemethods-perl libclass-mix-perl
> libclass-returnvalue-perl libclass-singleton-perl libclass-unload-perl
> libcontext-preserve-perl libconvert-basen-perl
> libcrypt-eksblowfish-perl libcrypt-gcrypt-perl
> libdata-dumper-concise-perl libdata-ical-perl libdata-page-perl
> libdate-calc-perl libdate-manip-perl libdatetime-event-ical-perl
> libdatetime-event-recurrence-perl libdatetime-format-builder-perl
> libdatetime-format-ical-perl libdatetime-format-mail-perl
> libdatetime-format-mysql-perl libdatetime-format-strptime-perl
> libdatetime-format-w3cdtf-perl libdatetime-locale-perl
> libdatetime-perl libdatetime-set-perl libdatetime-timezone-perl
> libdbd-mock-perl libdbd-sqlite2-perl libdbix-class-perl
> libdbix-class-schema-loader-perl libdbix-runsql-perl
> libdevel-cover-perl libdevel-stacktrace-ashtml-perl
> libdevel-symdump-perl libemail-abstract-perl libemail-date-perl
> libemail-simple-perl libemail-valid-perl libexception-class-perl
> libfile-nfslock-perl libfile-pushd-perl libfile-sharedir-perl
> libfile-slurp-perl libfilesys-notify-simple-perl libfont-ttf-perl
> libgd-barcode-perl libgraph-perl libgraphics-colornames-perl
> libgraphics-magick-perl libgraphicsmagick3 libgraphviz-perl
> libgravatar-url-perl libhash-multivalue-perl libheap-perl
> libhtml-scrubber-perl libhtml-tidy-perl libhttp-body-perl
> libhttp-oai-perl libhttp-parser-xs-perl libhttp-server-simple-perl
> libidzebra-2.0-0 libidzebra-2.0-dev libidzebra-2.0-mod-alvis
> libidzebra-2.0-mod-dom libidzebra-2.0-mod-grs-marc
> libidzebra-2.0-mod-grs-regx libidzebra-2.0-mod-grs-xml
> libidzebra-2.0-mod-text libidzebra-2.0-modules libimage-size-perl
> libio-multiplex-perl libio-pty-perl libipc-run-perl
> libipc-shareable-perl libjcode-pm-perl libjson-validator-perl
> liblibrary-callnumber-lc-perl liblingua-ispell-perl
> liblingua-stem-snowball-perl liblocale-currency-format-perl
> liblocale-maketext-lexicon-perl liblocale-po-perl liblog-dispatch-perl
> liblog-log4perl-perl libmail-sendmail-perl libmarc-charset-perl
> libmarc-record-perl libmarc-xml-perl libmath-base36-perl
> libmodern-perl-perl libmodule-bundled-files-perl libmodule-find-perl
> libmodule-refresh-perl libmojolicious-plugin-openapi-perl
> libnet-cidr-perl libnet-domain-tld-perl libnet-server-perl
> libnet-sftp-foreign-perl libnet-z3950-zoom-perl libnumber-format-perl
> libole-storage-lite-perl libopenoffice-oodoc-perl
> libparse-recdescent-perl libpath-class-perl libpdf-api2-perl
> libpdf-api2-simple-perl libpdf-fromhtml-perl libpdf-reuse-barcode-perl
> libpdf-reuse-perl libpdf-table-perl libpdf-writer-perl
> libplack-middleware-reverseproxy-perl libplack-perl
> libpod-coverage-perl libreadonly-perl libreadonly-xs-perl
> libschedule-at-perl libset-infinite-perl libsms-send-perl
> libspreadsheet-parseexcel-perl libspreadsheet-writeexcel-perl
> libsql-abstract-perl libsql-translator-perl libstring-crc32-perl
> libstring-random-perl libsub-uplevel-perl libswagger2-perl
> libtemplate-perl libtemplate-plugin-htmltotext-perl
> libtemplate-plugin-json-escape-perl libtemplate-plugin-stash-perl
> libtest-deep-perl libtest-longstring-perl libtest-mockmodule-perl
> libtest-pod-perl libtest-sharedfork-perl libtest-simple-perl
> libtest-strict-perl libtest-tcp-perl libtest-warn-perl
> libtest-www-mechanize-perl libtest-yaml-valid-perl libtext-bidi-perl
> libtext-csv-encoded-perl libtext-csv-perl libtext-csv-xs-perl
> libtext-pdf-perl libtext-recordparser-perl libtext-tabulardisplay-perl
> libtext-unaccent-perl libtext-vfile-asdata-perl libtidy-0.99-0
> libtie-ixhash-perl libtime-fake-perl libunicode-map-perl
> libuniversal-can-perl libuniversal-isa-perl libuniversal-require-perl
> libuuid-perl libwww-mechanize-perl libxml-dumper-perl
> libxml-filter-buffertext-perl libxml-libxslt-perl libxml-rss-perl
> libxml-sax-writer-perl libxml-twig-perl libxml-writer-perl
> libxml-xpathengine-perl libxml2-utils libyaz4 pwgen sgml-data starman
> tinymce ttf-dejavu ttf-dejavu-core ttf-dejavu-extra unzip xmlstarlet
> xsltproc yaz
> Use 'apt-get autoremove' to remove them.
> Done
> The following packages will be REMOVED:
>   koha-common libtest-exception-perl libtest-mockobject-perl
> The following NEW packages will be installed:
>   libmojolicious-plugin-openapi-perl
> The following packages have been kept back:
>   libtest-simple-perl
> 0 upgraded, 1 newly installed, 3 to remove and 1 not upgraded.
> Need to get 29.0 kB of archives.
> After this operation, 439 MB disk space will be freed.
> Do you want to continue? [Y/n]
> ======
>
> TIA,
> / Bruce /
> Bruce A. Metcalf
> Augustan Society Library
>
> _______________________________________________
> Koha mailing list  http://koha-community.org
> [hidden email]
> https://lists.katipo.co.nz/mailman/listinfo/koha

--
Héctor González
[hidden email]

_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Koha 17.11.01 released

Bruce A. Metcalf-3
In reply to this post by Chris Cormack-7
On 01/08/2018 03:59 PM, Chris Cormack wrote:
> What happens if you try
>
> sudo apt-get install libtest-simple-perl ?
Results:

======
root@store:/# apt-get install libtest-simple-perl
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer
required:
   [long list deleted]
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
   libmojolicious-plugin-openapi-perl
The following packages will be REMOVED:
   koha-common libplack-middleware-reverseproxy-perl libplack-perl
libtest-exception-perl libtest-mockobject-perl libtest-sharedfork-perl
libtest-tcp-perl starman
The following NEW packages will be installed:
   libmojolicious-plugin-openapi-perl
The following packages will be upgraded:
   libtest-simple-perl
1 upgraded, 1 newly installed, 8 to remove and 0 not upgraded.
Need to get 362 kB of archives.
After this operation, 439 MB disk space will be freed.
Do you want to continue? [Y/n]
======

Odd thought: Is there a clue in my /etc/apt/sources.list?

======
deb https://debian.koha-community.org/koha stable main
deb http://http.us.debian.org/debian/ jessie main non-free contrib
deb http://security.debian.org/ jessie/updates main
======

Thanks again all,
/ Bruce /
Bruce A. Metcalf
Augustan Society Library

_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Koha 17.11.01 released

Bruce A. Metcalf-3
In reply to this post by Hector Gonzalez
On 01/08/2018 09:14 PM, Hector Gonzalez wrote:

> Try this: apt-get install koha-common
>
> It should mark it as "to be installed", try to resolve its
> dependencies, and upgrade it to the latest version.  It looks like it
> is marked to be removed, and this it should be corrected.

That worked! Koha is now running 17.11.01.

A subsequent apt-get upgrade updated six packages, which is pretty
unremarkable.

But a subsequent apt-get dist-upgrade still wants to delete koha-common
and others:

======
root@store:/# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... The following packages were automatically
installed and are no longer required:
   [long list of files omitted]
Use 'apt-get autoremove' to remove them.
Done
The following packages will be REMOVED:
   koha-common libtest-exception-perl libtest-mockobject-perl
The following packages have been kept back:
   libtest-simple-perl
0 upgraded, 0 newly installed, 3 to remove and 1 not upgraded.
After this operation, 453 MB disk space will be freed.
Do you want to continue? [Y/n]
======

Curiouser and curiouser.

Thanks, at least I've made the update,
/ Bruce /
Bruce A. Metcalf
Augustan Society Library

_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha