Error after upgrading to 19.05

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Error after upgrading to 19.05

Jacopo
Hello everyone!
I am running Koha on a Debian Jessie server.
I installed Koha following the "package" method and I just updated it to
the latest version (19.05).
Unfortunately, something went wrong.

What I did:
sudo apt update
sudo apt upgrade
sudo apt install koha-common #as suggested in the documentation

The latter command triggered the update of thedatabase schema. A double
check with
sudo koha-upgrade-schema
gave no error.

I then reindexed both our libraries with:
sudo koha-rebuild-zebra -v -f <library>

And restarted koha-zebra, koha-sip, koha-plack.

I am currently not able to see the frontpage nor to login in the backend
(it gives my incorrect user/password).
I checked the logs here:
/var/log/koha/koha/opac-error.log

And it gives my these errors:

404.pl: Use of uninitialized value in concatenation (.) or string at
/usr/share/koha/lib/C4/Auth.pm line 551.
opac-export.pl: Use of uninitialized value in numeric ne (!=) at
/usr/share/koha/lib/C4/Ris.pm line 833.

In particular, the error from 404.pl recurs many times.

Any help or suggestion would be much appreciated!

Thanks!

Jacopo
_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Error after upgrading to 19.05

Mark Tompsett
Greetings,

It has been my experience that newer versions of 18.05 and higher are best
run on stretch.
And don't use Debian Buster yet. :)

GPML,
Mark Tompsett

P.S. 404 errors could be a result of differences in your apache instance
configuration file.
Upgrades don't change them. Compare the /etc/koha/...something.in file
against your
installed file, and see what you might need to add in.

_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Error after upgrading to 19.05

Jacopo
Dear Mark, dearl Alvaro,
thank you for your replies :)

Just an update:
- I moved to Debian 9
- set memcached correctly in my /etc/koha/sites/<library>/koha-conf.xml
(it is now running if I check the status in the about page of the intranet)

Current status:

* I am able to access the intranet and to search the catalogue from
there (styles loaded)
* I am not able to access correctly the opac/frontend: it takes minutes
just to load without styles. After few minutes it also retries some
records from the catalogue research

These are the errors present in /var/log/<library>/kohaopac-error.log

[Wed Jul 10 13:00:07 2019] 404.pl: Use of uninitialized value in
concatenation (.) or string at /usr/share/koha/lib/C4/Auth.pm line 584.,
referer: <opac.website>

[Wed Jul 10 12:59:55 2019] opac-search.pl: Use of uninitialized value in
concatenation (.) or string at /usr/share/koha/lib/C4/Auth.pm line 584.

In particular the first error happens each second.

Thanks for your help!

Best,
Jacopo


Il 10/07/19 02:09, Mark Tompsett ha scritto:

> Greetings,
>
> It has been my experience that newer versions of 18.05 and higher are best
> run on stretch.
> And don't use Debian Buster yet. :)
>
> GPML,
> Mark Tompsett
>
> P.S. 404 errors could be a result of differences in your apache instance
> configuration file.
> Upgrades don't change them. Compare the /etc/koha/...something.in file
> against your
> installed file, and see what you might need to add in.
>
> _______________________________________________
> Koha mailing list  http://koha-community.org
> [hidden email]
> https://lists.katipo.co.nz/mailman/listinfo/koha
>

_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Error after upgrading to 19.05

Jacopo
Hi,
just wanted to add, as a further explanation that
- the styles files (css/js) that the broswer tries to load have all the
suffix <filename>19.0501000.<extension>
- the same files are present here
/usr/share/koha/opac/htdocs/opac-tmpl/bootstrap but without extension
- the file including them is this one
/usr/share/koha/opac/htdocs/opac-tmpl/prog/it-IT/includes/doc-head-close.inc
but it doesn't show suffixes
- the line 584 of the file /usr/share/koha/lib/C4/Auth.pm is
mylibraryfirst => ( C4::Context->preference("SearchMyLibraryFirst") &&
C4::Context->userenv ) ? C4::Context->userenv->{'branch'} : '',

Thanks!
Jacopo


Il 10/07/19 13:09, Jacopo ha scritto:

> Dear Mark, dearl Alvaro,
> thank you for your replies :)
>
> Just an update:
> - I moved to Debian 9
> - set memcached correctly in my /etc/koha/sites/<library>/koha-conf.xml
> (it is now running if I check the status in the about page of the intranet)
>
> Current status:
>
> * I am able to access the intranet and to search the catalogue from
> there (styles loaded)
> * I am not able to access correctly the opac/frontend: it takes minutes
> just to load without styles. After few minutes it also retries some
> records from the catalogue research
>
> These are the errors present in /var/log/<library>/kohaopac-error.log
>
> [Wed Jul 10 13:00:07 2019] 404.pl: Use of uninitialized value in
> concatenation (.) or string at /usr/share/koha/lib/C4/Auth.pm line 584.,
> referer: <opac.website>
>
> [Wed Jul 10 12:59:55 2019] opac-search.pl: Use of uninitialized value in
> concatenation (.) or string at /usr/share/koha/lib/C4/Auth.pm line 584.
>
> In particular the first error happens each second.
>
> Thanks for your help!
>
> Best,
> Jacopo
>
>
> Il 10/07/19 02:09, Mark Tompsett ha scritto:
>> Greetings,
>>
>> It has been my experience that newer versions of 18.05 and higher are best
>> run on stretch.
>> And don't use Debian Buster yet. :)
>>
>> GPML,
>> Mark Tompsett
>>
>> P.S. 404 errors could be a result of differences in your apache instance
>> configuration file.
>> Upgrades don't change them. Compare the /etc/koha/...something.in file
>> against your
>> installed file, and see what you might need to add in.
>>
>> _______________________________________________
>> Koha mailing list  http://koha-community.org
>> [hidden email]
>> https://lists.katipo.co.nz/mailman/listinfo/koha
>>
>
> _______________________________________________
> Koha mailing list  http://koha-community.org
> [hidden email]
> https://lists.katipo.co.nz/mailman/listinfo/koha
>

_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Error after upgrading to 19.05

Alvaro Cornejo
Hi Jacopo

I guess your migration process failed somewhere.

I remember seen a post with the issue of having system calling files with
extensions like "19.0501000". If I do recall well it was due to something
wrong on the process.

Will try to find the related post.

Regards,

Alvaro
|-----------------------------------------------------------------------------------------------------------------|
Envíe y Reciba Datos y mensajes de Texto (SMS) hacia y desde cualquier
celular y Nextel
en el Perú, México y en mas de 180 paises. Use aplicaciones 2 vias via SMS
y GPRS online
              Visitenos en www.perusms.com


Le mer. 10 juil. 2019 à 07:20, Jacopo <[hidden email]> a écrit :

> Hi,
> just wanted to add, as a further explanation that
> - the styles files (css/js) that the broswer tries to load have all the
> suffix <filename>19.0501000.<extension>
> - the same files are present here
> /usr/share/koha/opac/htdocs/opac-tmpl/bootstrap but without extension
> - the file including them is this one
>
> /usr/share/koha/opac/htdocs/opac-tmpl/prog/it-IT/includes/doc-head-close.inc
> but it doesn't show suffixes
> - the line 584 of the file /usr/share/koha/lib/C4/Auth.pm is
> mylibraryfirst => ( C4::Context->preference("SearchMyLibraryFirst") &&
> C4::Context->userenv ) ? C4::Context->userenv->{'branch'} : '',
>
> Thanks!
> Jacopo
>
>
> Il 10/07/19 13:09, Jacopo ha scritto:
> > Dear Mark, dearl Alvaro,
> > thank you for your replies :)
> >
> > Just an update:
> > - I moved to Debian 9
> > - set memcached correctly in my /etc/koha/sites/<library>/koha-conf.xml
> > (it is now running if I check the status in the about page of the
> intranet)
> >
> > Current status:
> >
> > * I am able to access the intranet and to search the catalogue from
> > there (styles loaded)
> > * I am not able to access correctly the opac/frontend: it takes minutes
> > just to load without styles. After few minutes it also retries some
> > records from the catalogue research
> >
> > These are the errors present in /var/log/<library>/kohaopac-error.log
> >
> > [Wed Jul 10 13:00:07 2019] 404.pl: Use of uninitialized value in
> > concatenation (.) or string at /usr/share/koha/lib/C4/Auth.pm line 584.,
> > referer: <opac.website>
> >
> > [Wed Jul 10 12:59:55 2019] opac-search.pl: Use of uninitialized value in
> > concatenation (.) or string at /usr/share/koha/lib/C4/Auth.pm line 584.
> >
> > In particular the first error happens each second.
> >
> > Thanks for your help!
> >
> > Best,
> > Jacopo
> >
> >
> > Il 10/07/19 02:09, Mark Tompsett ha scritto:
> >> Greetings,
> >>
> >> It has been my experience that newer versions of 18.05 and higher are
> best
> >> run on stretch.
> >> And don't use Debian Buster yet. :)
> >>
> >> GPML,
> >> Mark Tompsett
> >>
> >> P.S. 404 errors could be a result of differences in your apache
> instance
> >> configuration file.
> >> Upgrades don't change them. Compare the /etc/koha/...something.in file
> >> against your
> >> installed file, and see what you might need to add in.
> >>
> >> _______________________________________________
> >> Koha mailing list  http://koha-community.org
> >> [hidden email]
> >> https://lists.katipo.co.nz/mailman/listinfo/koha
> >>
> >
> > _______________________________________________
> > Koha mailing list  http://koha-community.org
> > [hidden email]
> > https://lists.katipo.co.nz/mailman/listinfo/koha
> >
>
> _______________________________________________
> Koha mailing list  http://koha-community.org
> [hidden email]
> https://lists.katipo.co.nz/mailman/listinfo/koha
>
_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Error after upgrading to 19.05

Alvaro Cornejo
Hi Jacopo

Look for the message title " [Koha] Problem with upgrading Koha from 17.11
to 18.11 " dated march 22nd

The case is very similar. It does not provide a final solution, but it can
give you ideas...

Regards,

Alvaro



|-----------------------------------------------------------------------------------------------------------------|
Envíe y Reciba Datos y mensajes de Texto (SMS) hacia y desde cualquier
celular y Nextel
en el Perú, México y en mas de 180 paises. Use aplicaciones 2 vias via SMS
y GPRS online
              Visitenos en www.perusms.com


Le mer. 10 juil. 2019 à 09:45, Alvaro Cornejo <[hidden email]> a
écrit :

> Hi Jacopo
>
> I guess your migration process failed somewhere.
>
> I remember seen a post with the issue of having system calling files with
> extensions like "19.0501000". If I do recall well it was due to something
> wrong on the process.
>
> Will try to find the related post.
>
> Regards,
>
> Alvaro
>
> |-----------------------------------------------------------------------------------------------------------------|
> Envíe y Reciba Datos y mensajes de Texto (SMS) hacia y desde cualquier
> celular y Nextel
> en el Perú, México y en mas de 180 paises. Use aplicaciones 2 vias via SMS
> y GPRS online
>               Visitenos en www.perusms.com
>
>
> Le mer. 10 juil. 2019 à 07:20, Jacopo <[hidden email]> a écrit :
>
>> Hi,
>> just wanted to add, as a further explanation that
>> - the styles files (css/js) that the broswer tries to load have all the
>> suffix <filename>19.0501000.<extension>
>> - the same files are present here
>> /usr/share/koha/opac/htdocs/opac-tmpl/bootstrap but without extension
>> - the file including them is this one
>>
>> /usr/share/koha/opac/htdocs/opac-tmpl/prog/it-IT/includes/doc-head-close.inc
>> but it doesn't show suffixes
>> - the line 584 of the file /usr/share/koha/lib/C4/Auth.pm is
>> mylibraryfirst => ( C4::Context->preference("SearchMyLibraryFirst") &&
>> C4::Context->userenv ) ? C4::Context->userenv->{'branch'} : '',
>>
>> Thanks!
>> Jacopo
>>
>>
>> Il 10/07/19 13:09, Jacopo ha scritto:
>> > Dear Mark, dearl Alvaro,
>> > thank you for your replies :)
>> >
>> > Just an update:
>> > - I moved to Debian 9
>> > - set memcached correctly in my /etc/koha/sites/<library>/koha-conf.xml
>> > (it is now running if I check the status in the about page of the
>> intranet)
>> >
>> > Current status:
>> >
>> > * I am able to access the intranet and to search the catalogue from
>> > there (styles loaded)
>> > * I am not able to access correctly the opac/frontend: it takes minutes
>> > just to load without styles. After few minutes it also retries some
>> > records from the catalogue research
>> >
>> > These are the errors present in /var/log/<library>/kohaopac-error.log
>> >
>> > [Wed Jul 10 13:00:07 2019] 404.pl: Use of uninitialized value in
>> > concatenation (.) or string at /usr/share/koha/lib/C4/Auth.pm line 584.,
>> > referer: <opac.website>
>> >
>> > [Wed Jul 10 12:59:55 2019] opac-search.pl: Use of uninitialized value
>> in
>> > concatenation (.) or string at /usr/share/koha/lib/C4/Auth.pm line 584.
>> >
>> > In particular the first error happens each second.
>> >
>> > Thanks for your help!
>> >
>> > Best,
>> > Jacopo
>> >
>> >
>> > Il 10/07/19 02:09, Mark Tompsett ha scritto:
>> >> Greetings,
>> >>
>> >> It has been my experience that newer versions of 18.05 and higher are
>> best
>> >> run on stretch.
>> >> And don't use Debian Buster yet. :)
>> >>
>> >> GPML,
>> >> Mark Tompsett
>> >>
>> >> P.S. 404 errors could be a result of differences in your apache
>> instance
>> >> configuration file.
>> >> Upgrades don't change them. Compare the /etc/koha/...something.in
>> file
>> >> against your
>> >> installed file, and see what you might need to add in.
>> >>
>> >> _______________________________________________
>> >> Koha mailing list  http://koha-community.org
>> >> [hidden email]
>> >> https://lists.katipo.co.nz/mailman/listinfo/koha
>> >>
>> >
>> > _______________________________________________
>> > Koha mailing list  http://koha-community.org
>> > [hidden email]
>> > https://lists.katipo.co.nz/mailman/listinfo/koha
>> >
>>
>> _______________________________________________
>> Koha mailing list  http://koha-community.org
>> [hidden email]
>> https://lists.katipo.co.nz/mailman/listinfo/koha
>>
>
_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Error after upgrading to 19.05

Jacopo
Dear Alvaro,
thank you very much!
You pointed me in the right direction!
To summarise, the suggestion provided the 25th of March by Chris Cormack
(many thanks to him too) solved the issue:
https://lists.katipo.co.nz/public/koha/2019-March/052591.html
I had, in /etc/koha, 2 files named in a similar way
apache-shared-opac.conf.dpkg-dist apache-shared-opac.conf .
The second, that was in use by my apache2 conf file, was missing the
rewrite rule for css and js. I simply renamed the
apache-shared-opac.conf with the suffix -old and moved the
apache-shared-opac.conf.dpkg-dist to be the current
apache-shared-opac.conf and restarted apache2.

I still get the same error by C4/Auth.pm line 584, 'though.

All the best,
Jacopo


Il 10/07/19 16:51, Alvaro Cornejo ha scritto:

> Hi Jacopo
>
> Look for the message title " [Koha] Problem with upgrading Koha from
> 17.11 to 18.11 " dated march 22nd
>
> The case is very similar. It does not provide a final solution, but it
> can give you ideas...
>
> Regards,
>
> Alvaro
>
>
>  
> |-----------------------------------------------------------------------------------------------------------------|
> Envíe y Reciba Datos y mensajes de Texto (SMS) hacia y desde cualquier
> celular y Nextel
> en el Perú, México y en mas de 180 paises. Use aplicaciones 2 vias via
> SMS y GPRS online
>               Visitenos en www.perusms.com <http://www.perusms.com>
>
>
> Le mer. 10 juil. 2019 à 09:45, Alvaro Cornejo <[hidden email]
> <mailto:[hidden email]>> a écrit :
>
>     Hi Jacopo
>
>     I guess your migration process failed somewhere.
>
>     I remember seen a post with the issue of having system calling files
>     with extensions like "19.0501000". If I do recall well it was due to
>     something wrong on the process.
>
>     Will try to find the related post.
>
>     Regards,
>
>     Alvaro
>     |-----------------------------------------------------------------------------------------------------------------|
>     Envíe y Reciba Datos y mensajes de Texto (SMS) hacia y desde
>     cualquier celular y Nextel
>     en el Perú, México y en mas de 180 paises. Use aplicaciones 2 vias
>     via SMS y GPRS online
>                   Visitenos en www.perusms.com <http://www.perusms.com>
>
>
>     Le mer. 10 juil. 2019 à 07:20, Jacopo <[hidden email]
>     <mailto:[hidden email]>> a écrit :
>
>         Hi,
>         just wanted to add, as a further explanation that
>         - the styles files (css/js) that the broswer tries to load have
>         all the
>         suffix <filename>19.0501000.<extension>
>         - the same files are present here
>         /usr/share/koha/opac/htdocs/opac-tmpl/bootstrap but without
>         extension
>         - the file including them is this one
>         /usr/share/koha/opac/htdocs/opac-tmpl/prog/it-IT/includes/doc-head-close.inc
>         but it doesn't show suffixes
>         - the line 584 of the file /usr/share/koha/lib/C4/Auth.pm is
>         mylibraryfirst => (
>         C4::Context->preference("SearchMyLibraryFirst") &&
>         C4::Context->userenv ) ? C4::Context->userenv->{'branch'} : '',
>
>         Thanks!
>         Jacopo
>
>
>         Il 10/07/19 13:09, Jacopo ha scritto:
>         > Dear Mark, dearl Alvaro,
>         > thank you for your replies :)
>         >
>         > Just an update:
>         > - I moved to Debian 9
>         > - set memcached correctly in my
>         /etc/koha/sites/<library>/koha-conf.xml
>         > (it is now running if I check the status in the about page of
>         the intranet)
>         >
>         > Current status:
>         >
>         > * I am able to access the intranet and to search the catalogue
>         from
>         > there (styles loaded)
>         > * I am not able to access correctly the opac/frontend: it
>         takes minutes
>         > just to load without styles. After few minutes it also retries
>         some
>         > records from the catalogue research
>         >
>         > These are the errors present in
>         /var/log/<library>/kohaopac-error.log
>         >
>         > [Wed Jul 10 13:00:07 2019] 404.pl <http://404.pl>: Use of
>         uninitialized value in
>         > concatenation (.) or string at /usr/share/koha/lib/C4/Auth.pm
>         line 584.,
>         > referer: <opac.website>
>         >
>         > [Wed Jul 10 12:59:55 2019] opac-search.pl
>         <http://opac-search.pl>: Use of uninitialized value in
>         > concatenation (.) or string at /usr/share/koha/lib/C4/Auth.pm
>         line 584.
>         >
>         > In particular the first error happens each second.
>         >
>         > Thanks for your help!
>         >
>         > Best,
>         > Jacopo
>         >
>         >
>         > Il 10/07/19 02:09, Mark Tompsett ha scritto:
>         >> Greetings,
>         >>
>         >> It has been my experience that newer versions of 18.05 and
>         higher are best
>         >> run on stretch.
>         >> And don't use Debian Buster yet. :)
>         >>
>         >> GPML,
>         >> Mark Tompsett
>         >>
>         >> P.S. 404 errors could be a result of differences in your
>         apache instance
>         >> configuration file.
>         >> Upgrades don't change them. Compare the
>         /etc/koha/...something.in <http://something.in> file
>         >> against your
>         >> installed file, and see what you might need to add in.
>         >>
>         >> _______________________________________________
>         >> Koha mailing list  http://koha-community.org
>         >> [hidden email] <mailto:[hidden email]>
>         >> https://lists.katipo.co.nz/mailman/listinfo/koha
>         >>
>         >
>         > _______________________________________________
>         > Koha mailing list  http://koha-community.org
>         > [hidden email] <mailto:[hidden email]>
>         > https://lists.katipo.co.nz/mailman/listinfo/koha
>         >
>
>         _______________________________________________
>         Koha mailing list  http://koha-community.org
>         [hidden email] <mailto:[hidden email]>
>         https://lists.katipo.co.nz/mailman/listinfo/koha
>

_______________________________________________
Koha mailing list  http://koha-community.org
[hidden email]
https://lists.katipo.co.nz/mailman/listinfo/koha