Domain for Koha Server (URL SET UP)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Domain for Koha Server (URL SET UP)

Evil-A
Hello,

I will probably ask something really easy to fix, but I am totally new to
this, so...

I installed and configure Koha Version 19.11, also I made a little
customization on my OPAC.

I am able to see my Koha through both Intranet and Internet (only with an
IP)
In the intranet I use 11.11.11.11:80 (OPAC) and 11.11.11.11:8080 (Admin)
On internet I use 111.111.111.11:80 (OPAC) and 111.111.111.11:8080 (Admin)
No issues until here.

I also have a domain active... mydomain.abc.de

But I've been trying different ways to set up the URL so everybody can see
my sites but unsuccessful.

My /etc/hosts looks like:

127.0.0.1 localhost
127.0.1.1 library

111.111.111.11 library.mydomain.abc.de
111.111.111.11 library-admin.mydomain.abc.de

Then my /etc/koha/koha-sites/.conf is:

DOMAIN=".mydomain.abc.de" ----  here I also tried with the real IP
(111.111.111.11)
INTRAPORT="8080"
INTRAPREFIX="lybrary"
INTRASUFFIX="-admin"
OPACPORT="80"
OPACPREFIX="library"
INTRASUFFIX=""

Not working at this point...

So I was reading some posts here end they suggest to edit the
/etc/koha/koha-sites.conf

I added a ServerAlias like this:

# OPAC
<VirtualHost *:80>

ServerName librarylocalhost
ServerAlias library.mydomain.abc.de

# Intranet
<VirtualHost *:8080>
ServerName library-adminlocalhost
ServerAlias library-admin.mydomain.abc.de

then I tried

# OPAC
<VirtualHost *:80>

ServerName library


# Intranet
<VirtualHost *:8080>
ServerName library-admin

And

# OPAC
<VirtualHost *:80>

ServerName library
ServerAlias library.mydomain.abc.de

# Intranet
<VirtualHost *:8080>
ServerName library-admin
ServerAlias library-admin.mydomain.abc.de

But still not working

I read another post that suggest to make some modifications on
koha-httpd.conf but couldn´t find that file,  other post suggest to edit
file /etc/apache2/sites-enabled/koha.conf but that file don't even exist on
my server.

I´ve been trying with all of these configurations but until now I am no able
to reach my sites with an url.

Does anybody have an idea on what I am doing wrong...

Thanks



--
Sent from: http://koha.1045719.n5.nabble.com/Koha-general-f3047918.html
_______________________________________________

Koha mailing list  http://koha-community.org
[hidden email]
Unsubscribe: https://lists.katipo.co.nz/mailman/listinfo/koha
Reply | Threaded
Open this post in threaded view
|

Re: Domain for Koha Server (URL SET UP)

jcoehoorn
I think you want this:

DOMAIN=".mydomain.abc.de" -
INTRAPORT="8080"
INTRAPREFIX=""
INTRASUFFIX="-admin"
OPACPORT="80"
OPACPREFIX=""
OPACSUFFIX=""

You will also need a public DNS service to publish the "
library.mydomain.abc.de" and "library-admin.mydomain.abc.de". This is not
typically hosted yourself or configured on your own server, but done
through an outside service provider. This is how people on the internet
find out what IP those names belong to. If you try to host this yourself,
you have a problem where people must already know where you are to find
out... where you are.

And speaking of your IP addresses, those IPs look suspicious. You don't get
to choose your own public IP address. They are assigned by your ISP. Did
you really manage to get 111.111.111.11 assigned to you? What do you see if
you visit whatismyip.com from the koha server? That is IP you need to use
for your public address. If this is not a static IP address, you will also
need a mechanism to update your DNS records whenever it changes.

Also, the internal 11.11.11.11 address is not valid for internal networks.
Your local internal network should only use addresses beginning with
10.x.x.x, 192.168.x.x, or 172.16.x.x. Anything else is not correct, and
will create conflicts with real systems on the internet.

====================================================

After those fixes, if everything else is okay you should be online.
However, there are some additional changes you will want to make.

First, if you really want the intranet available on the public internet,
you really out to use HTTPS. That means acquiring and installing a
certificate (see letsencrypt.com) and supporting connections over port 443
(or 8443) instead of 8080, and making changes to turn on TLS in the apache
config. Additionally, if you allow users to log into the OPAC you need to
do the same there. It's NEVER okay to allow users to submit a password over
an unencrypted (non-HTTPS) link.

Really, it sounds like you may need to find a local IT consultant who
understands networking and can physically sit at your machine for a couple
hours to make these things happen. If the server is otherwise working, a
couple hours at their billable rate is about how long this should take, but
you should only need to do it once to get things going. If you don't
already have a good understanding of public networking, we're unlikely to
be able to help you over the mailing list. :(

Joel Coehoorn
Director of Information Technology
402.363.5603
*[hidden email] <[hidden email]>*

*Please contact [hidden email] <[hidden email]> for technical
assistance.*


The mission of York College is to transform lives through
Christ-centered education and to equip students for lifelong service to
God, family, and society


On Tue, May 19, 2020 at 3:00 AM Evil-A <[hidden email]> wrote:

> Hello,
>
> I will probably ask something really easy to fix, but I am totally new to
> this, so...
>
> I installed and configure Koha Version 19.11, also I made a little
> customization on my OPAC.
>
> I am able to see my Koha through both Intranet and Internet (only with an
> IP)
> In the intranet I use 11.11.11.11:80 (OPAC) and 11.11.11.11:8080 (Admin)
> On internet I use 111.111.111.11:80 (OPAC) and 111.111.111.11:8080 (Admin)
> No issues until here.
>
> I also have a domain active... mydomain.abc.de
>
> But I've been trying different ways to set up the URL so everybody can see
> my sites but unsuccessful.
>
> My /etc/hosts looks like:
>
> 127.0.0.1 localhost
> 127.0.1.1 library
>
> 111.111.111.11 library.mydomain.abc.de
> 111.111.111.11 library-admin.mydomain.abc.de
>
> Then my /etc/koha/koha-sites/.conf is:
>
> DOMAIN=".mydomain.abc.de" ----  here I also tried with the real IP
> (111.111.111.11)
> INTRAPORT="8080"
> INTRAPREFIX="lybrary"
> INTRASUFFIX="-admin"
> OPACPORT="80"
> OPACPREFIX="library"
> INTRASUFFIX=""
>
> Not working at this point...
>
> So I was reading some posts here end they suggest to edit the
> /etc/koha/koha-sites.conf
>
> I added a ServerAlias like this:
>
> # OPAC
> <VirtualHost *:80>
>
> ServerName librarylocalhost
> ServerAlias library.mydomain.abc.de
>
> # Intranet
> <VirtualHost *:8080>
> ServerName library-adminlocalhost
> ServerAlias library-admin.mydomain.abc.de
>
> then I tried
>
> # OPAC
> <VirtualHost *:80>
>
> ServerName library
>
>
> # Intranet
> <VirtualHost *:8080>
> ServerName library-admin
>
> And
>
> # OPAC
> <VirtualHost *:80>
>
> ServerName library
> ServerAlias library.mydomain.abc.de
>
> # Intranet
> <VirtualHost *:8080>
> ServerName library-admin
> ServerAlias library-admin.mydomain.abc.de
>
> But still not working
>
> I read another post that suggest to make some modifications on
> koha-httpd.conf but couldn´t find that file,  other post suggest to edit
> file /etc/apache2/sites-enabled/koha.conf but that file don't even exist on
> my server.
>
> I´ve been trying with all of these configurations but until now I am no
> able
> to reach my sites with an url.
>
> Does anybody have an idea on what I am doing wrong...
>
> Thanks
>
>
>
> --
> Sent from: http://koha.1045719.n5.nabble.com/Koha-general-f3047918.html
> _______________________________________________
>
> Koha mailing list  http://koha-community.org
> [hidden email]
> Unsubscribe: https://lists.katipo.co.nz/mailman/listinfo/koha
>
_______________________________________________

Koha mailing list  http://koha-community.org
[hidden email]
Unsubscribe: https://lists.katipo.co.nz/mailman/listinfo/koha