To summarise, rather than adding lots of ->search_for_x, ->search_for_y, ->search_for_z methods to our objects I'd like to come up with some guidelines on code re-use and method naming conventions. (along with improving our current perldoc procedure to make the docs more informative and helpful, but let's cover that in another bug ;) ).
Please take a look at the example code options I've presented in the bug and chip in with your thoughts, suggestions. Jonathan has already made some great suggestions and I'd love to see us working towards having clearer conventions and more code re-use.
Registered in the United Kingdom No. 06416372 VAT Reg No. 925 7211 30
The information contained in this email message may be privileged, confidential and protected from disclosure. If you are not the intended recipient, any dissemination, distribution or copying is strictly prohibited. If you think that you have received this email message in error, please email the sender at [hidden email]