[Bug 5616] UTF-8 problem in Card View

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Bug 5616] UTF-8 problem in Card View

bugzilla-daemon
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5616

M. de Rooy <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Priority|P5                          |PATCH-Sent
            Version|rel_3_2                     |master
       Patch Status|Patch Pushed                |Needs Signoff

--- Comment #10 from M. de Rooy <[hidden email]> 2011-10-10 12:59:53 UTC ---
Frederick,
I saw that in your patch you encoded the data.
AFAIK you should decode data coming from outside the program and you could
leave the encoding to perl when outputting the data as long as you have the
encoding of your file handles correctly.
Nevertheless, I still think your patch will work in most cases.
Note that it is not needed to decode data from LibXSLT if the stylesheet
contains the instruction to use UTF8 (See CPAN.)
I would suggest to add the instruction to use UTF8 in the HTML header.

Sending a small additional patch for that purpose. Could you check it?

--
Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA Contact for the bug.
_______________________________________________
Koha-bugs mailing list
[hidden email]
http://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-bugs
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/